summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2023-02-01 00:27:18 +0100
committerMatěj Cepl <mcepl@cepl.eu>2023-02-02 12:51:31 +0100
commit61ef70e1818e969e766d185dcd05bf7306a746bc (patch)
tree7a96fbd28443df7205a3a3d0a34bdb08359c3c6c
parentbbd2c986ea61d424f3d7e936c7b42c7be773dafe (diff)
downloadm2crypto-61ef70e1818e969e766d185dcd05bf7306a746bc.tar.gz
Make Windows tests working again.
Fixes #315
-rw-r--r--appveyor.yml7
-rw-r--r--dev-requirements.txt1
-rw-r--r--setup.py2
3 files changed, 5 insertions, 5 deletions
diff --git a/appveyor.yml b/appveyor.yml
index eabda21..cc67d19 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -5,8 +5,8 @@ environment:
secure: oqWqarxnd4H23FMywnlQeg==
PASS:
secure: j/VSxdYJ7mdR44u8OdywLg==
- X86_OPENSSL_INSTALLER: Win32OpenSSL-1_1_1k.exe
- X64_OPENSSL_INSTALLER: Win64OpenSSL-1_1_1k.exe
+ X86_OPENSSL_INSTALLER: Win32OpenSSL-1_1_1s.exe
+ X64_OPENSSL_INSTALLER: Win64OpenSSL-1_1_1s.exe
matrix:
@@ -139,8 +139,7 @@ install:
- "c:\\%X64_OPENSSL_INSTALLER% /silent /verysilent /DIR=C:\\OpenSSL-1-1-Win64"
- ECHO "Install pywin32"
- - curl -o "%PYWIN32%" -fsSL "https://github.com/mhammond/pywin32/releases/download/%PYWIN32_RELEASE%/%PYWIN32%"
- - "%PYTHON%\\Scripts\\easy_install.exe %PYWIN32%"
+ - "python -m pip install pywin32"
#- mkdir pywin32
#- 7z x "%PYWIN32%" -opywin32
#- xcopy /e "pywin32\\PLATLIB" "%PYTHON%\\Lib\\site-packages"
diff --git a/dev-requirements.txt b/dev-requirements.txt
index 381ec31..5417914 100644
--- a/dev-requirements.txt
+++ b/dev-requirements.txt
@@ -1,5 +1,6 @@
-r requirements.txt
twine
+wheel
flake8
typing; python_version < "3.5"
# Intentionally not in requirements.txt, because only those use it need
diff --git a/setup.py b/setup.py
index 04ac8c7..a7abcec 100644
--- a/setup.py
+++ b/setup.py
@@ -81,7 +81,7 @@ def openssl_version(ossldir, req_ver, required=False):
ver = libssl.OpenSSL_version_num()
log.debug("ctypes: ver = %s", hex(ver))
# for OpenSSL < 1.1.0
- except AttributeError:
+ except (AttributeError, FileNotFoundError):
ver = None
file = os.path.join(ossldir, 'include', 'openssl', 'opensslv.h')