summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2017-10-05 13:37:01 +0200
committerMatěj Cepl <mcepl@cepl.eu>2017-10-05 23:51:00 +0200
commit720d47b423d3732212c76c724fe3ec67c279f806 (patch)
treed5c200b343cfa082ad15923f9ee557fe5604f55e
parent0b6842aa2a6d2e201468422927cf0fdbc33d8677 (diff)
downloadm2crypto-720d47b423d3732212c76c724fe3ec67c279f806.tar.gz
Fix metadata for new release.0.27.0
Also, fix licence (it is MIT, not BSD). Fixes #121
-rw-r--r--CHANGES11
-rw-r--r--M2Crypto/__init__.py2
-rw-r--r--README.rst2
-rw-r--r--setup.py3
4 files changed, 15 insertions, 3 deletions
diff --git a/CHANGES b/CHANGES
index 655fd10..f892776 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,14 @@
+0.27.0 - 2017-10-05
+-------------------
+- Fix licence: it is MIT, not BSD
+- At least minimal support of SNI in httpslib.
+- Small bugfixes and cleanups.
+- More effort to make build system more robust (now should work even on
+ Debian LTS).
+- Restore m2.rsa_set_e() and m2.rsa_set_n().
+- Make sure that every exceptional return throws and exception and vice
+ versa.
+
0.26.4 - 2017-09-26
-------------------
- Proper fix of deprecation warning for OpenSSL 1.1.0
diff --git a/M2Crypto/__init__.py b/M2Crypto/__init__.py
index b99cf27..a166894 100644
--- a/M2Crypto/__init__.py
+++ b/M2Crypto/__init__.py
@@ -19,7 +19,7 @@ Copyright 2008-2011 Heikki Toivonen. All rights reserved.
"""
# noqa
from distutils.version import StrictVersion
-__version__ = '0.26.4'
+__version__ = '0.27.0'
version = __version__ # type: str
version_info = StrictVersion(__version__).version
diff --git a/README.rst b/README.rst
index b86e67c..f9a5940 100644
--- a/README.rst
+++ b/README.rst
@@ -43,7 +43,7 @@ working for you.
- And much more.
-M2Crypto is released under a very liberal BSD-style licence. See
+M2Crypto is released under a very liberal MIT licence. See
LICENCE for details.
To install, see the file INSTALL.
diff --git a/setup.py b/setup.py
index 572c3e0..c070424 100644
--- a/setup.py
+++ b/setup.py
@@ -318,7 +318,7 @@ setuptools.setup(
version=__get_version(),
description='M2Crypto: A Python crypto and SSL toolkit',
long_description=long_description_text,
- license='BSD-style license',
+ license='MIT',
platforms=['any'],
author='Ng Pheng Siong',
author_email='ngps at sandbox rulemaker net',
@@ -328,6 +328,7 @@ setuptools.setup(
classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
'Operating System :: OS Independent',
'Programming Language :: C',
'Programming Language :: Python',