summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2021-06-14 20:53:41 +0200
committerMatěj Cepl <mcepl@cepl.eu>2021-06-14 20:53:41 +0200
commit945cb6b0b128941d4f4fa124bc67dad3754ccdf8 (patch)
treecae3905ff00f584e378821ab4abbc0886bfe4c5e
parent565d63117339baf3d0d296fc2d5f9038218a9d79 (diff)
downloadm2crypto-945cb6b0b128941d4f4fa124bc67dad3754ccdf8.tar.gz
Install openssl explicitly on openSUSE.
-rw-r--r--.gitlab-ci.yml2
1 files changed, 1 insertions, 1 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 03b7d58..83c4d59 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -64,6 +64,6 @@ opensuse:
script:
- zypper refresh
- zypper install -y pattern:devel_rpm_build pattern:devel_C_C++ osc
- - zypper install -y swig python3-devel libopenssl-1_1-devel python3-service_identity python3-setuptools python3-Twisted python3-parameterized
+ - zypper install -y swig python3-devel libopenssl-1_1-devel openssl-1_1 python3-service_identity python3-setuptools python3-Twisted python3-parameterized
- python3 setup.py clean build
- PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v