summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2023-03-17 16:15:24 +0100
committerMatěj Cepl <mcepl@cepl.eu>2023-03-17 16:39:14 +0100
commit9f5281735e1683d275b813947e4c50fb6e4c13d3 (patch)
tree80f377f0cdc6fbc70b2835e5bcb5582ecd879101
parentc9d91c58b697a4b1b1364ade0acd772fd23035cc (diff)
downloadm2crypto-9f5281735e1683d275b813947e4c50fb6e4c13d3.tar.gz
Generates TAP.
Not sure how important it is, but it looks neat.
-rw-r--r--.gitlab-ci.yml20
-rw-r--r--appveyor.yml6
-rw-r--r--dev-requirements.txt1
3 files changed, 15 insertions, 12 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 4593aa8..f13c3f4 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -6,7 +6,7 @@ python27:
- apt-get install -y swig libssl-dev python-dev openssl python-twisted python-setuptools python-pip python-typing
- python -mpip install --user -r dev-requirements.txt
- python setup.py clean build
- - PYTHONPATH=$(readlink -f build/lib.*) python -munittest discover -v
+ - PYTHONPATH=$(readlink -f build/lib.*) python -mtap discover -v
allow_failure:
exit_codes: 1
@@ -18,17 +18,17 @@ python35:
- apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip
- python3 -mpip install --user -r dev-requirements.txt
- python3 setup.py clean build
- - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -mtap discover -v
python3:
image: python:3
when: always
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip
+ - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip tappy
- python3 -mpip install --user -r dev-requirements.txt
- python3 setup.py clean build
- - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -mtap discover -v
fedora:
image: fedora:latest
@@ -36,8 +36,9 @@ fedora:
script:
- dnf install --refresh -y @development-tools fedora-packager rpmdevtools
- dnf install -y swig python3-devel openssl-devel openssl python3-setuptools python3-twisted
+ - python3 -mpip install --user -r dev-requirements.txt
- python3 setup.py clean build
- - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -mtap discover -v
fedora-rawhide:
image: registry.fedoraproject.org/fedora:rawhide
@@ -45,8 +46,9 @@ fedora-rawhide:
script:
- dnf install --refresh -y @development-tools fedora-packager rpmdevtools
- dnf install -y swig python3-devel openssl-devel openssl python3-setuptools python3-twisted
+ - python3 -mpip install --user -r dev-requirements.txt
- python3 setup.py clean build
- - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -mtap discover -v
centos7:
image: centos:7
@@ -58,7 +60,7 @@ centos7:
- yum install -y swig python36-devel openssl openssl-devel python36-service-identity python36-setuptools python36-pip python36-Twisted python36-parameterized
- python3 -mpip install --user -r dev-requirements.txt
- python3 setup.py clean build
- - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -mtap discover -v
opensuse:
image: opensuse/tumbleweed
@@ -66,6 +68,6 @@ opensuse:
script:
- zypper refresh
- zypper install -y pattern:devel_rpm_build pattern:devel_C_C++ osc
- - zypper install -y swig python3-devel libopenssl-devel openssl python3-service_identity python3-setuptools python3-Twisted
+ - zypper install -y swig python3-devel libopenssl-devel openssl python3-service_identity python3-setuptools python3-Twisted python3-tap.py
- python3 setup.py clean build
- - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -mtap discover -v
diff --git a/appveyor.yml b/appveyor.yml
index 2523750..e5f00fb 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -12,8 +12,8 @@ environment:
secure: oqWqarxnd4H23FMywnlQeg==
PASS:
secure: j/VSxdYJ7mdR44u8OdywLg==
- X86_OPENSSL_INSTALLER: Win32OpenSSL-1_1_1s.exe
- X64_OPENSSL_INSTALLER: Win64OpenSSL-1_1_1s.exe
+ X86_OPENSSL_INSTALLER: Win32OpenSSL-1_1_1t.exe
+ X64_OPENSSL_INSTALLER: Win64OpenSSL-1_1_1t.exe
# Random password, never used anywhere else
APPVEYOR_RDP_PASSWORD: MmXt9yk3rNah3CGcRWad3XD
PYPI_USERNAME: __token__
@@ -169,7 +169,7 @@ build_script:
test_script:
- "dir .\\build"
- "SET PYTHONPATH=.\\build\\lib.%PYTHONPATH_DIR%"
- - "%PYTHON%\\python.exe -munittest discover -v tests"
+ - "%PYTHON%\\python.exe -mtap discover -v tests"
after_test:
# If tests are successful, create a whl package for the project.
diff --git a/dev-requirements.txt b/dev-requirements.txt
index 5417914..59b9fb2 100644
--- a/dev-requirements.txt
+++ b/dev-requirements.txt
@@ -2,6 +2,7 @@
twine
wheel
flake8
+tap.py
typing; python_version < "3.5"
# Intentionally not in requirements.txt, because only those use it need
# this very specialized module.