summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2023-02-02 15:37:57 +0100
committerMatěj Cepl <mcepl@cepl.eu>2023-02-02 17:11:27 +0100
commitb6917efc045dfdb5fb40804f88c7ade2c2841677 (patch)
tree5da40eaad48362b2561ef19f2e8455cfa1834a1f
parent67eefd5a811a52048a93b111cd0407b5b17be8d8 (diff)
downloadm2crypto-b6917efc045dfdb5fb40804f88c7ade2c2841677.tar.gz
Allow failing of Python 2.7 tests.
-rw-r--r--appveyor.yml10
1 files changed, 6 insertions, 4 deletions
diff --git a/appveyor.yml b/appveyor.yml
index a05cc17..471aea8 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,7 +1,7 @@
branches:
only:
- master
- - windows
+ - /windows.*/
environment:
global:
@@ -16,7 +16,6 @@ environment:
APPVEYOR_RDP_PASSWORD: MmXt9yk3rNah3CGcRWad3XD
matrix:
-
# Pre-installed Python versions, which Appveyor may upgrade to
# a later point release.
@@ -100,6 +99,10 @@ environment:
PYWIN32_RELEASE: b228
PYTHONPATH_DIR: "win-amd64-2.7"
+matrix:
+ allow_failures:
+ - PYTHON: "C:\\Python27-x64"
+
nuget:
account_feed: true
@@ -107,7 +110,6 @@ install:
# Install non-python dependencies using chocolatey package manager
- choco install -r -y swig
-
# Install Python (from the official .msi of http://python.org) and pip when
# not already installed.
- ps: if (-not(Test-Path($env:PYTHON))) { & appveyor\install.ps1 }
@@ -167,7 +169,7 @@ test_script:
after_test:
# If tests are successful, create a whl package for the project.
- "%PYTHON%\\python.exe setup.py bdist_wheel"
- - ps: "ls dist"
+ - "dir .\\dist"
artifacts:
# Archive the generated wheel package in the ci.appveyor.com build report.