summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2021-01-13 08:22:49 +0100
committerMatěj Cepl <mcepl@cepl.eu>2021-01-14 14:29:59 +0100
commitd93ee3c676929ae1ca9b3acb94a8ce9c3f9c936d (patch)
tree89c2e9e411f932029cefbea4f3f45c98fb7e0705
parent73fbd1e646f6bbf202d4418bae80eb9941fbf552 (diff)
downloadm2crypto-d93ee3c676929ae1ca9b3acb94a8ce9c3f9c936d.tar.gz
Fix main.yml
Perhaps unittest is enough, after all Fixes #288
-rw-r--r--.github/workflows/main.yml6
-rw-r--r--.gitlab-ci.yml30
-rw-r--r--dev-requirements.txt1
3 files changed, 24 insertions, 13 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 20e54af..3d8aea3 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -31,5 +31,7 @@ jobs:
python -mflake8 . --count --exit-zero --exclude six.py --max-complexity=10 --max-line-length=127 --statistics
- name: Running the test suite
run: |
- python setup.py clean build test -v
-
+ set -x
+ python setup.py clean build
+ export PYTHONPATH=$(readlink -f build/lib.*)
+ python -munittest discover -v
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 99ede2a..03b7d58 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -3,27 +3,30 @@ python27:
when: always
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev python-dev openssl python-twisted python-setuptools python-pip
+ - apt-get install -y swig libssl-dev python-dev openssl python-twisted python-setuptools python-pip python-typing python-parameterized
- python -mpip install --user -r dev-requirements.txt
- - python setup.py clean build test
+ - python setup.py clean build
+ - PYTHONPATH=$(readlink -f build/lib.*) python -munittest discover -v
python35:
image: python:3.5
when: always
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip
+ - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip python3-parameterized
- python3 -mpip install --user -r dev-requirements.txt
- - python3 setup.py clean build test
+ - python3 setup.py clean build
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
python3:
image: python:3
when: always
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip
+ - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip python3-parameterized
- python3 -mpip install --user -r dev-requirements.txt
- - python3 setup.py clean build test
+ - python3 setup.py clean build
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
fedora:
image: fedora:30
@@ -31,7 +34,8 @@ fedora:
script:
- dnf install --refresh -y @development-tools fedora-packager rpmdevtools
- dnf install -y swig python3-devel openssl-devel openssl python3-setuptools python3-twisted python3-parameterized
- - python3 setup.py clean build test
+ - python3 setup.py clean build
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
fedora-rawhide:
image: registry.fedoraproject.org/fedora:rawhide
@@ -39,17 +43,20 @@ fedora-rawhide:
script:
- dnf install --refresh -y @development-tools fedora-packager rpmdevtools
- dnf install -y swig python3-devel openssl-devel openssl python3-setuptools python3-twisted python3-parameterized
- - python3 setup.py clean build test
+ - python3 setup.py clean build
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
centos7:
image: centos:7
when: always
script:
+ - yum install -y https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
- yum makecache
- yum groups install -y "Development Tools"
- - yum install -y swig python3-devel openssl openssl-devel python3-service-identity python3-setuptools python3-pip python3-Twisted
+ - yum install -y swig python36-devel openssl openssl-devel python36-service-identity python36-setuptools python36-pip python36-Twisted python36-parameterized
- python3 -mpip install --user -r dev-requirements.txt
- - python3 setup.py clean build test
+ - python3 setup.py clean build
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
opensuse:
image: opensuse/tumbleweed
@@ -58,4 +65,5 @@ opensuse:
- zypper refresh
- zypper install -y pattern:devel_rpm_build pattern:devel_C_C++ osc
- zypper install -y swig python3-devel libopenssl-1_1-devel python3-service_identity python3-setuptools python3-Twisted python3-parameterized
- - python3 setup.py clean build test
+ - python3 setup.py clean build
+ - PYTHONPATH=$(readlink -f build/lib.*) python3 -munittest discover -v
diff --git a/dev-requirements.txt b/dev-requirements.txt
index 636f9a0..9ee222f 100644
--- a/dev-requirements.txt
+++ b/dev-requirements.txt
@@ -2,6 +2,7 @@
parameterized
twine
flake8
+typing; python_version < "3.5"
# Intentionally not in requirements.txt, because only those use it need
# this very specialized module.
twisted