summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2020-12-07 22:56:32 +0100
committerMatěj Cepl <mcepl@cepl.eu>2020-12-07 23:49:55 +0100
commitd9dec89a2d46c21459f9d2644f914f1b3f5d8144 (patch)
tree2b9dcd1c7131b4c37a75dc055575bf70c24c9a5d
parentcb4529c45e96107d754a59c0904311695bddb350 (diff)
downloadm2crypto-d9dec89a2d46c21459f9d2644f914f1b3f5d8144.tar.gz
Some distros don't distribute parameterized
-rw-r--r--.github/workflows/main.yml2
-rw-r--r--.gitlab-ci.yml9
-rw-r--r--dev-requirements.txt3
-rw-r--r--requirements.txt1
4 files changed, 9 insertions, 6 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 7b23f84..f63bc46 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -22,7 +22,7 @@ jobs:
- name: Install dependencies
run: |
python -m pip install --upgrade pip flake8
- if [ -f requirements.txt ]; then python -m pip install -r requirements.txt; fi
+ if [ -f dev-requirements.txt ]; then python -m pip install -r dev-requirements.txt; fi
- name: Lint with flake8
run: |
# stop the build if there are Python syntax errors or undefined names
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 7f9b4f4..ff74632 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -3,7 +3,8 @@ python27:
when: always
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev python-dev openssl python-twisted python-setuptools python-parameterized
+ - apt-get install -y swig libssl-dev python-dev openssl python-twisted python-setuptools python-pip
+ - python -mpip install --user parameterized
- python setup.py clean build test
python35:
@@ -11,7 +12,8 @@ python35:
when: always
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-parameterized
+ - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip
+ - python3 -mpip install --user parameterized
- python3 setup.py clean build test
python3:
@@ -19,7 +21,8 @@ python3:
when: always
script:
- apt-get update -q -y
- - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-parameterized
+ - apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip
+ - python3 -mpip install --user parameterized
- python3 setup.py clean build test
fedora:
diff --git a/dev-requirements.txt b/dev-requirements.txt
index 6c4932c..8404828 100644
--- a/dev-requirements.txt
+++ b/dev-requirements.txt
@@ -1,2 +1,3 @@
-wheel
+-r requirements.txt
+parameterized
twine
diff --git a/requirements.txt b/requirements.txt
index 5ac42fe..2309722 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,2 +1 @@
wheel
-parameterized