summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2020-12-08 19:15:08 +0100
committerMatěj Cepl <mcepl@cepl.eu>2020-12-08 19:15:08 +0100
commitdc1da568d2ab73038e6e116b121d59e0f59a2553 (patch)
tree5183b91752d4a0039e75483acaff984dfcbcb0db
parent044ae976a04e524ba001f63d437ecb866ebeff68 (diff)
downloadm2crypto-dc1da568d2ab73038e6e116b121d59e0f59a2553.tar.gz
Fix typo parametrized -> parameterized
-rw-r--r--.gitlab-ci.yml8
-rw-r--r--CHANGES2
-rw-r--r--M2Crypto/__init__.py2
-rw-r--r--setup.py2
4 files changed, 7 insertions, 7 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 790eac0..99ede2a 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -4,7 +4,7 @@ python27:
script:
- apt-get update -q -y
- apt-get install -y swig libssl-dev python-dev openssl python-twisted python-setuptools python-pip
- - python -mpip install --user parameterized
+ - python -mpip install --user -r dev-requirements.txt
- python setup.py clean build test
python35:
@@ -13,7 +13,7 @@ python35:
script:
- apt-get update -q -y
- apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip
- - python3 -mpip install --user parameterized
+ - python3 -mpip install --user -r dev-requirements.txt
- python3 setup.py clean build test
python3:
@@ -22,7 +22,7 @@ python3:
script:
- apt-get update -q -y
- apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted python3-pip
- - python3 -mpip install --user parameterized
+ - python3 -mpip install --user -r dev-requirements.txt
- python3 setup.py clean build test
fedora:
@@ -48,7 +48,7 @@ centos7:
- yum makecache
- yum groups install -y "Development Tools"
- yum install -y swig python3-devel openssl openssl-devel python3-service-identity python3-setuptools python3-pip python3-Twisted
- - python3 -mpip install --user parameterized
+ - python3 -mpip install --user -r dev-requirements.txt
- python3 setup.py clean build test
opensuse:
diff --git a/CHANGES b/CHANGES
index 10e6274..225a365 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,7 +10,7 @@
- Stop playing with swig in setup.py, we don't support swig 1.* anymore.
- Fix dereferencing of pointers (gl#m2crypto/m2crypto#281)
- Replace deprecated PyObject_AsReadBuffer with our own shim.
-- Use parametrized to create parametrized tests (new external
+- Use parameterized to create parameterized tests (new external
dependency).
- Only use DigestSign() and DigestUpdate() with OpenSSL >= 1.1.1
- Expose all the X509_V_FLAG
diff --git a/M2Crypto/__init__.py b/M2Crypto/__init__.py
index f0fd255..4fc489f 100644
--- a/M2Crypto/__init__.py
+++ b/M2Crypto/__init__.py
@@ -19,7 +19,7 @@ Copyright 2008-2011 Heikki Toivonen. All rights reserved.
"""
# noqa
from distutils.version import StrictVersion
-__version__ = '0.37.0'
+__version__ = '0.37.1'
version = __version__ # type: str
version_info = StrictVersion(__version__).version
diff --git a/setup.py b/setup.py
index e39f51c..8e4a1e2 100644
--- a/setup.py
+++ b/setup.py
@@ -33,7 +33,7 @@ logging.basicConfig(format='%(levelname)s:%(funcName)s:%(message)s',
stream=sys.stdout, level=logging.INFO)
log = logging.getLogger('setup')
-requires_list = ['parametrized']
+requires_list = ['parameterized']
if (2, 6) < sys.version_info[:2] < (3, 5):
requires_list = ['typing']
if sys.version_info[0] > 2: