summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2020-07-13 18:20:58 +0200
committerMatěj Cepl <mcepl@cepl.eu>2020-11-20 20:51:21 +0100
commitdd050dcf51b77aa8e5d45bc11235a3c59cea2acd (patch)
treef5367a2a8f9b712dc21673bd0b755b33c7c5542f
parent65997b1761b3ccbaef84cbc4ffc24585717e8b02 (diff)
downloadm2crypto-dd050dcf51b77aa8e5d45bc11235a3c59cea2acd.tar.gz
Create python-package.yml
Add standard template via GitHub webpage.
-rw-r--r--.github/workflows/main.yml35
1 files changed, 35 insertions, 0 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
new file mode 100644
index 0000000..5330f27
--- /dev/null
+++ b/.github/workflows/main.yml
@@ -0,0 +1,35 @@
+# This workflow will install Python dependencies, run tests and lint with a variety of Python versions
+# For more information see: https://help.github.com/actions/language-and-framework-guides/using-python-with-github-actions
+
+name: Python package
+
+on: [push, pull_request]
+
+jobs:
+ test:
+
+ runs-on: ubuntu-latest
+ strategy:
+ matrix:
+ python-version: [2.7, 3.5, 3.6, 3.7, 3.8]
+
+ steps:
+ - uses: actions/checkout@v2
+ - name: Set up Python ${{ matrix.python-version }}
+ uses: actions/setup-python@v2
+ with:
+ python-version: ${{ matrix.python-version }}
+ - name: Install dependencies
+ run: |
+ python -m pip install --upgrade pip flake8
+ if [ -f requirements.txt ]; then pip3 install -r requirements.txt; fi
+ - name: Lint with flake8
+ run: |
+ # stop the build if there are Python syntax errors or undefined names
+ python -mflake8 . --count --exclude six.py --select=E9,F63,F7,F82 --show-source --statistics
+ # exit-zero treats all errors as warnings. The GitHub editor is 127 chars wide
+ python -mflake8 . --count --exit-zero --exclude six.py --max-complexity=10 --max-line-length=127 --statistics
+ - name: Running the test suite
+ run: |
+ python setup.py clean build test -v
+