summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2020-12-08 11:16:52 +0100
committerMatěj Cepl <mcepl@cepl.eu>2020-12-08 12:22:30 +0100
commitea3e5ce44844f12ffdf40257eabf20622027a125 (patch)
tree2379cacabf079960d18e6d4ffdebee582046438e
parentdbefb4bea52ff9b2f768be555094fae3508cb0b5 (diff)
downloadm2crypto-ea3e5ce44844f12ffdf40257eabf20622027a125.tar.gz
Add centos7 GitLab-CI target
-rw-r--r--.gitlab-ci.yml10
1 files changed, 10 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index ff74632..790eac0 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -41,6 +41,16 @@ fedora-rawhide:
- dnf install -y swig python3-devel openssl-devel openssl python3-setuptools python3-twisted python3-parameterized
- python3 setup.py clean build test
+centos7:
+ image: centos:7
+ when: always
+ script:
+ - yum makecache
+ - yum groups install -y "Development Tools"
+ - yum install -y swig python3-devel openssl openssl-devel python3-service-identity python3-setuptools python3-pip python3-Twisted
+ - python3 -mpip install --user parameterized
+ - python3 setup.py clean build test
+
opensuse:
image: opensuse/tumbleweed
when: always