summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2019-04-26 15:59:44 +0200
committerMatěj Cepl <mcepl@cepl.eu>2019-04-26 15:59:44 +0200
commiteb4525ce1add0c2d5e9f2286807af52902fd94a4 (patch)
tree791cdbfb799304e44e357068a6ab16f9ea2993ee
parent6a89548fa719be679a9c9d21ebd9c9a09b230ed5 (diff)
downloadm2crypto-eb4525ce1add0c2d5e9f2286807af52902fd94a4.tar.gz
Stop pretending to support Python 3.4.
-rw-r--r--.gitlab-ci.yml8
-rw-r--r--INSTALL.rst2
-rw-r--r--setup.py1
3 files changed, 3 insertions, 8 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index a2d8dbe..b864651 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -22,11 +22,10 @@ python27:
- apt-get install -y swig libssl1.0-dev python-dev openssl python-twisted python-setuptools
- python setup.py clean build test
-python34:
- image: python:3.4
+python35:
+ image: python:3.5
when: always
script:
- - echo 'deb http://ftp.debian.org/debian jessie-backports main' > /etc/apt/sources.list.d/backports-jessie.list
- apt-get update -q -y
- apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted
- python3 setup.py clean build test
@@ -35,7 +34,6 @@ python3:
image: python:3
when: always
script:
- - echo 'deb http://ftp.debian.org/debian jessie-backports main' >/etc/apt/sources.list.d/backports-jessie.list
- apt-get update -q -y
- apt-get install -y swig libssl-dev python3-dev openssl python3-setuptools python3-twisted
- python3 setup.py clean build test
@@ -44,7 +42,6 @@ fedora:
image: fedora:26
when: always
script:
- # - dnf upgrade --refresh -y
- dnf install --refresh -y @development-tools fedora-packager rpmdevtools
- dnf install -y swig python-devel openssl-devel openssl python-setuptools python-twisted
- python setup.py clean build test
@@ -53,7 +50,6 @@ fedora3:
image: fedora:26
when: always
script:
- # - dnf upgrade --refresh -y
- dnf install --refresh -y @development-tools fedora-packager rpmdevtools
- dnf install -y swig python3-devel openssl-devel openssl python3-setuptools python3-twisted
- python3 setup.py clean build test
diff --git a/INSTALL.rst b/INSTALL.rst
index 222f018..f0ab79e 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -8,7 +8,7 @@ Pre-requisites
The following is required to *use* M2Crypto (once installed):
-- ``Python 2.6``, ``2.7``, ``3.4``, or newer
+- ``Python 2.6``, ``2.7``, ``3.5``, or newer
- ``OpenSSL 1.0.1e`` or newer
To *install* M2Crypto, you must be able to compile and link C sources
diff --git a/setup.py b/setup.py
index f85e008..08c73cf 100644
--- a/setup.py
+++ b/setup.py
@@ -377,7 +377,6 @@ setuptools.setup(
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',