summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2015-10-14 07:07:57 +0200
committerMatěj Cepl <mcepl@cepl.eu>2015-10-16 01:51:49 +0200
commitf48671f1687d7d06c77f0c4e3c7722a878cf732d (patch)
tree3b95e838d7df921b56ad6379f08d7b1e34978b98
parentb78674a5b745b9c83c48c5a9e3c8e9f0a25a87e9 (diff)
downloadm2crypto-f48671f1687d7d06c77f0c4e3c7722a878cf732d.tar.gz
Add missing files to MANIFEST.in
I haven’t tested really fix contained in 0.22.5 so I have missed some other files which were missing to run ``setup.py test`` successfully. Fixes #62
-rw-r--r--MANIFEST.in9
-rw-r--r--setup.py2
2 files changed, 10 insertions, 1 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index edfc120..79c65e5 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,4 +1,13 @@
include SWIG/*.i
include SWIG/*.h
include SWIG/*.def
+recursive-include tests *.py *.pem *.der *.b64 README
+recursive-include doc
+recursive-include demo
+recursive-include contrib
+include INSTALL
+include CHANGES
+include epydoc.conf
+include LICENSE
+include fedora-setup.sh
exclude M2Crypto/_m2crypto.py
diff --git a/setup.py b/setup.py
index 3d12c2e..9f1ae0f 100644
--- a/setup.py
+++ b/setup.py
@@ -148,7 +148,7 @@ used to provide SSL for Twisted.''',
],
ext_modules=[m2crypto],
- test_suite='unittest.collector',
+ test_suite='tests.alltests.suite',
install_requires=requires_list,
cmdclass={'build_ext': _M2CryptoBuildExt}
)