summaryrefslogtreecommitdiff
path: root/CHANGES
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2016-07-21 17:26:44 +0200
committerMatěj Cepl <mcepl@cepl.eu>2016-07-22 11:27:09 +0200
commitd29f4a83b4ef542f3fc6f998e7672666e142043d (patch)
tree87d4814416af7afca2013ef7ef72dd85c15dbaeb /CHANGES
parent44ef7a99b3aca2cbdb348ce732f49723967cb2f7 (diff)
downloadm2crypto-d29f4a83b4ef542f3fc6f998e7672666e142043d.tar.gz
Add changelog from 0.21.1 onwards.
Diffstat (limited to 'CHANGES')
-rw-r--r--CHANGES66
1 files changed, 66 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 8355a94..99295e6 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,69 @@
+0.25.0 - 2016-03-21
+-------------------
+- More cleanups, removal of obsolete stuff, and moves towards py3k
+ compatibility.
+- Add support for EC.get_builtin_curves() and use it for testing.
+- Enable AES CTR mode
+- Bundle-in six module v. 1.10.0
+- add rand_file_name and rand_status
+- remove all LHASH fiddling
+- Extend Travis and GitLab CI configuration to test also py3k (with
+ allowed_failures) and CentOS6 (on GitLab CI).
+- Add CONTRIBUTORS.rst. Thank you!
+- Add PEP-484 type hints in comments to all Python files (except for
+ tests)
+- Use context managers for file handling wherever possible instead of
+ leaking open file descriptors.
+- Improve defaults handling for SSL_CTX_new().
+- Fix PGP tests to actually run
+
+0.24.0 - 2016-03-21
+-------------------
+- More cleanups, removal of obsolete stuff, and moves towards py3k
+ compatibility.
+- Add DSA.pub_key_from_params() factory function (and m2.dsa_set_pub()).
+- Allow import/export of EC public key with binary values
+- Add EVP.load_key_string_pubkey() function, as well as helper functions
+- Add EVP.get_digestbyname() functionality.
+- Convert documentation to rST (and add instructions for building on Mac
+ OS X)
+- Another round of fixing multiarch building.
+- Disable tests with weak ciphers on some platforms (Debain)
+
+0.23.0 - 2016-01-29
+-------------------
+- Add Travis and GitLab CI configurations
+- Allow building without SSLv2
+- More cleanups and removing obsolete code
+- Fix README
+- Fix buffer overflow in pkcs5_pbkdf2_hmac_sha1
+- First moves towards Python 3 compatibility
+- Removed rather large and completely unmaintained demo/ subdirectory
+ (now in a separate repo https://gitlab.com/m2crypto/m2crypto_demo)
+- Automatically generated test data files
+- Finally fix building on multiarch systems
+- All objects derived from BIO.BIO now could work as context managers
+- Switch setup.py to setuptools
+
+0.22.5 - 2015-10-13
+-------------------
+- Add forgoteen SWIG/*.h among distributed files.
+
+0.22.4 - 2015-10-13
+-------------------
+- Matěj Cepl takes over leadership of the upstream maintenance
+- Fedora/RHEL distribution patches merged to the main development
+ (mainly, but not only, upgrading to the more recent versions of
+ OpenSSL, swig which is now at 3.0.5, but anything above 2.0.4 is
+ supported as well, and python which now has to be at least 2.6).
+- Tons of cleaning up the code for obsolete constructs, PEP8ization,
+ etc.
+
+0.22.3 - 2014-01-22
+-------------------
+(released by Martin Paljak, later development started on top of 0.21.1
+with his improvements cherry picked to the new development branch)
+
0.21.1 - 2011-01-15
-------------------
- Distribution fix