summaryrefslogtreecommitdiff
path: root/appveyor.yml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2018-02-24 11:54:28 +0100
committerMatěj Cepl <mcepl@cepl.eu>2018-02-28 08:33:56 +0100
commit81e7de136fde6ec1a88ac0d6cbab62536d4b1107 (patch)
tree4d641429bd802433685fea9b954e8f4199f427b7 /appveyor.yml
parente548fdb60e64ad4cde88403d026354675326ad16 (diff)
downloadm2crypto-81e7de136fde6ec1a88ac0d6cbab62536d4b1107.tar.gz
Generate better set of binaries for Windows
Also, include (optionally, default off) openssl DLLs in win32 binary builds. Fixes #202
Diffstat (limited to 'appveyor.yml')
-rw-r--r--appveyor.yml30
1 files changed, 13 insertions, 17 deletions
diff --git a/appveyor.yml b/appveyor.yml
index 75f0bf8..84254aa 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -1,11 +1,5 @@
environment:
global:
- # SDK v7.0 MSVC Express 2008's SetEnv.cmd script will fail if the
- # /E:ON and /V:ON options are not enabled in the batch script intepreter
- # See: http://stackoverflow.com/a/13751649/163740
- CMD_IN_ENV: "cmd /E:ON /V:ON /C .\\appveyor\\run_with_env.cmd"
- OPENSSL_PATH: "C:\\Program Files\\OpenSSL"
-
# PyPI login environment:
USER:
secure: oqWqarxnd4H23FMywnlQeg==
@@ -19,16 +13,17 @@ environment:
- PYTHON: "C:\\Python36"
PYTHON_VERSION: "3.6.x" # currently 3.6.4
PYTHON_ARCH: "32"
- OPENSSL_PATH: "C:\\OpenSSL-Win32"
+ OPENSSL_PATH: "C:\\OpenSSL-1-1-Win32"
PYWIN32: "pywin32-222.win32-py3.6.exe"
PYWIN32_RELEASE: b222
- - PYTHON: "C:\\Python36"
+ - PYTHON: "C:\\Python36-x64"
PYTHON_VERSION: "3.6.x" # currently 3.6.4
- PYTHON_ARCH: "32"
- OPENSSL_PATH: "C:\\OpenSSL-1-1-Win32"
- PYWIN32: "pywin32-222.win32-py3.6.exe"
+ PYTHON_ARCH: "64"
+ OPENSSL_PATH: "C:\\OpenSSL-1-1-Win64"
+ PYWIN32: "pywin32-222.win-amd64-py3.6.exe"
PYWIN32_RELEASE: b222
+ APPVEYOR_BUILD_WORKER_IMAGE: Visual Studio 2017
- PYTHON: "C:\\Python27"
PYTHON_VERSION: "2.7.x" # currently 2.7.9
@@ -47,7 +42,7 @@ environment:
- PYTHON: "C:\\Python27-x64"
PYTHON_VERSION: "2.7.x" # currently 2.7.9
PYTHON_ARCH: "64"
- OPENSSL_PATH: "C:\\OpenSSL-Win64"
+ OPENSSL_PATH: "C:\\OpenSSL-1-1-Win64"
PYWIN32: "pywin32-222.win-amd64-py2.7.exe"
PYWIN32_RELEASE: b222
@@ -94,7 +89,7 @@ install:
# compiled extensions and are not provided as pre-built wheel packages,
# pip will build them from source using the MSVC compiler matching the
# target Python version and architecture
- - "%CMD_IN_ENV% pip install -r dev-requirements.txt"
+ - "%PYTHON%\\Scripts\\pip.exe install -r dev-requirements.txt"
- ECHO "Install OpenSSL 1.1.0 32bit"
- curl -o Win32OpenSSL-1_1_0g.exe -sSL https://slproweb.com/download/Win32OpenSSL-1_1_0g.exe
@@ -117,8 +112,9 @@ install:
- ECHO "Filesystem root:"
- ps: "ls \"C:/\""
+ - ps: "ls \"C:/OpenSSL-Win32\""
- ECHO "Installed SDKs:"
- - ps: "ls \"C:/Program Files/Microsoft SDKs/Windows\""
+ - ps: if (Test-Path "C:/Program Files/Microsoft SDKs/Windows") { ls "C:/Program Files/Microsoft SDKs/Windows" }
- ECHO "Appveyor OpenSSL Version (%OPENSSL_VERSION%)"
- "%OPENSSL_PATH%/bin/openssl.exe version"
@@ -127,14 +123,14 @@ install:
- "%PYTHON%\\python.exe -c \"import ssl; print(getattr(ssl, 'OPENSSL_VERSION', None))\""
build_script:
- - "%CMD_IN_ENV% python setup.py build --openssl=\"%OPENSSL_PATH%\""
+ - "%PYTHON%\\python.exe setup.py build --openssl=\"%OPENSSL_PATH%\" --bundledlls"
test_script:
- - "%CMD_IN_ENV% python setup.py test"
+ - "%PYTHON%\\python.exe setup.py test"
after_test:
# If tests are successful, create a whl package for the project.
- - "%CMD_IN_ENV% python setup.py bdist_wheel bdist_wininst bdist_msi"
+ - "%PYTHON%\\python.exe setup.py bdist_wheel bdist_wininst bdist_msi"
- ps: "ls dist"
artifacts: