summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2019-11-24 23:32:50 +0100
committerMatěj Cepl <mcepl@cepl.eu>2019-11-24 23:32:50 +0100
commit1bd4b72bf946c1f5327232de20ec68ba1369daeb (patch)
treeb451c3a4897011c6e39b55dca7add98c9bdc686b /setup.py
parentde7238b4b9ee89885e50d030968e421990ff050e (diff)
downloadm2crypto-1bd4b72bf946c1f5327232de20ec68ba1369daeb.tar.gz
Stop using string module, which has been deprecated.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 35cfc89..4acffff 100644
--- a/setup.py
+++ b/setup.py
@@ -19,7 +19,6 @@ import platform
import re
import shlex
import shutil
-import string
import subprocess
import sys
@@ -344,7 +343,9 @@ def __get_version(): # noqa
with open('M2Crypto/__init__.py') as init_file:
for line in init_file:
if line.startswith('__version__ ='):
- return line.split('=')[1].strip(string.whitespace + "'")
+ # Originally string.whitespace, but it is deprecated
+ string_whitespace = ' \t\n\r\x0b\x0c'
+ return line.split('=')[1].strip(string_whitespace + "'")
long_description_text = '''\