summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKonstantinos Koukopoulos <koukopoulos@gmail.com>2013-06-01 16:40:58 +0300
committerMatěj Cepl <mcepl@cepl.eu>2016-04-28 10:13:16 +0200
commit1ff0fe549d3bbd039af88297e8f74bd40bc5962a (patch)
tree09b89f8a8566bb72230178fda133e2b929dff752 /setup.py
parentdd3c6ebbba9d2abe5cd661391c7af052f4b737fc (diff)
downloadm2crypto-1ff0fe549d3bbd039af88297e8f74bd40bc5962a.tar.gz
Don't ignore any --swig-opts passed on the command line.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e228d96..b1ce746 100644
--- a/setup.py
+++ b/setup.py
@@ -75,6 +75,9 @@ class _M2CryptoBuildExt(build_ext.build_ext):
build_ext.build_ext.finalize_options(self)
+ if self.swig_opts is None:
+ self.swig_opts = []
+
_openssl = next((x.split('=')[1] for x in sys.argv
if '--openssl=' in x), None)
if _openssl and os.path.isdir(_openssl):