summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2017-10-07 19:46:27 +0200
committerMatěj Cepl <mcepl@cepl.eu>2017-10-07 21:14:26 +0200
commit232b457ec2e9896d4b205f894a7ba333e8811116 (patch)
tree0be1290337dd572ad6d9ec453db6f28cc076990d /setup.py
parent35f5e5c3e735a27c6af552744ae3dbdeab819c6a (diff)
downloadm2crypto-232b457ec2e9896d4b205f894a7ba333e8811116.tar.gz
Remove all PGP modules.
Fixes #182. Reasoning for the change was: I think we are just lying to ourselves when we keep PGP module in the repository. 1. It is not used. Over a year, there is ``DeprecationWarning`` asking anybody who uses the module to contact me. Nobody ever did. Even the previous maintainer of M2Crypto [did not know how to use it](https://stackoverflow.com/a/1042139/164233), and that was 2009. Whole Stack Overflow is full of vague comments like “hopefully M2Crypto.PGP will help you”, but I have not found on DuckDuckGo one example of use of M2Crypto.PGP 2. The main point of M2Crypto is to be Python bindings for OpenSSL. And truly most of the other M2Crypto code is just a tiny wrapper around C functions. That is not so with M2Crypto.PGP. It is basically reimplementation of PGP keys manipulation functions with Python with rather large set of Python objects and complicated computations. There are very few calls to any C code at all and most work is done by series of Python functions. And, obviously, PGP != OpenSSL. 3. There is very tiny test suite for M2Crypto.PGP. It is basically just running ``PGP.load_pubring()``, which does exercise a lot of the module, but certainly it is far from the rigorous unit testing. 4. And of course, it is completely broken under Python 3, and I have no idea how to fix it (especially given 1. I don't want to spend too much time on it).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index c070424..6b8713e 100644
--- a/setup.py
+++ b/setup.py
@@ -308,8 +308,7 @@ M2Crypto is the most complete Python wrapper for OpenSSL featuring RSA, DSA,
DH, EC, HMACs, message digests, symmetric ciphers (including AES); SSL
functionality to implement clients and servers; HTTPS extensions to Python's
httplib, urllib, and xmlrpclib; unforgeable HMAC'ing AuthCookies for web
-session management; FTP/TLS client and server; S/MIME; ZServerSSL: A HTTPS
-server for Zope and ZSmime: An S/MIME messenger for Zope. M2Crypto can also be
+session management; FTP/TLS client and server; S/MIME; M2Crypto can also be
used to provide SSL for Twisted. Smartcards supported through the Engine
interface.'''