summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJoe Julian <jjulian@io.com>2015-05-19 23:54:08 -0700
committerMatěj Cepl <mcepl@cepl.eu>2016-12-13 17:49:24 +0100
commit3dfc27a5dbf2b05cc13044b1af553f80458065a3 (patch)
tree077704f7b4d54f4dfe573528dd39beb3cce5e43f /setup.py
parent15700be1fb95a735c571b191692848b462b2607a (diff)
downloadm2crypto-3dfc27a5dbf2b05cc13044b1af553f80458065a3.tar.gz
Use swig generated python loader
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 11d9334..b271711 100644
--- a/setup.py
+++ b/setup.py
@@ -156,6 +156,8 @@ class _M2CryptoBuildExt(build_ext.build_ext):
self.swig_opts.extend(['-I%s' % i for i in self.include_dirs])
self.swig_opts.append('-includeall')
+ self.swig_opts.extend(['-outdir',
+ os.path.join(os.getcwd(), 'M2Crypto')])
self.swig_opts.append('-modern')
self.swig_opts.append('-builtin')
@@ -240,7 +242,7 @@ else:
lib_sources = ['SWIG/_m2crypto_wrap.c']
-m2crypto = setuptools.Extension(name='M2Crypto.__m2crypto',
+m2crypto = setuptools.Extension(name='M2Crypto._m2crypto',
sources=lib_sources,
extra_compile_args=['-DTHREADING'],
# Uncomment to build Universal Mac binaries