summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDuncan Macleod <duncan.macleod@ligo.org>2019-01-18 13:48:23 +0000
committerMatěj Cepl <mcepl@cepl.eu>2019-03-04 17:06:51 +0000
commit471582f654d65512a25839bb7f67eb92d0281f3d (patch)
treea535c87669dc48df4cfcd85adbde8820f3c73fc4 /setup.py
parentefb1580c58de87f1dda4f11e439bb01d1231aeeb (diff)
downloadm2crypto-471582f654d65512a25839bb7f67eb92d0281f3d.tar.gz
setup.py: use ${CPP} as path to cpp
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a2689d3..7efd6d4 100644
--- a/setup.py
+++ b/setup.py
@@ -50,7 +50,7 @@ def _get_additional_includes():
'*Visual*', 'VC', 'include')
err = glob.glob(globmask)
else:
- pid = subprocess.Popen(['cpp', '-Wp,-v', '-'],
+ pid = subprocess.Popen([os.environ.get('CPP', 'cpp'), '-Wp,-v', '-'],
stdin=open(os.devnull, 'r'),
stdout=subprocess.PIPE,
stderr=subprocess.PIPE)