summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2017-12-08 18:48:36 +0100
committerMatěj Cepl <mcepl@cepl.eu>2018-01-08 11:48:37 +0100
commit4c4450cc29a0fc28cc26c88c49ee5d03c9a28316 (patch)
tree043971c1befef114361d1987dc45f86ffe1083d5 /setup.py
parentbf36300f0608bf013f7596aa1dfaf3b2e0e33200 (diff)
downloadm2crypto-4c4450cc29a0fc28cc26c88c49ee5d03c9a28316.tar.gz
Bundle-in unittest2 0.5.1 for Python 2.6.
Fixes #195
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 4 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index c3452a5..1d0ed19 100644
--- a/setup.py
+++ b/setup.py
@@ -14,6 +14,7 @@ import glob
import logging
import os
import platform
+import re
import string
import subprocess
import sys
@@ -33,13 +34,10 @@ log = logging.getLogger('setup')
REQUIRED_SWIG_VERSION = '2.0.4'
-if sys.version_info[:2] <= (2, 6):
- # This covers hopefully only RHEL-6 (users of any other 2.6 Pythons
- # ... Solaris?, *BSD? ... should file an issue and be prepared to
- # help with adjusting this script.
- requires_list = ["unittest2==0.5.1"]
-else:
+if sys.version_info[:2] > (2, 6):
requires_list = ['typing']
+else:
+ requires_list = []
def _get_additional_includes():