summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2017-09-29 11:01:35 +0200
committerMatěj Cepl <mcepl@cepl.eu>2017-10-12 17:05:44 +0200
commit676cf9c264165a1f66c01f97d47812593e8f7548 (patch)
tree01145450c99696540a7266288ddd430a3f2cd25d /setup.py
parentfc9b6e633d0132f62c8988fbd4413b4f71f24907 (diff)
downloadm2crypto-676cf9c264165a1f66c01f97d47812593e8f7548.tar.gz
subprocess.Popen() process returns bytes and bytes don't have split() method.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index bfae544..9c794d9 100644
--- a/setup.py
+++ b/setup.py
@@ -49,7 +49,8 @@ def _get_additional_includes():
stdout=subprocess.PIPE,
stderr=subprocess.PIPE)
_, err = pid.communicate()
- err = [line.lstrip() for line in err.split('\n') if line and line[0] == ' ']
+ err = [line.lstrip() for line in err.decode('utf8').split('\n')
+ if line and line[0] == ' ']
return err