summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2017-09-20 22:53:31 +0200
committerMatěj Cepl <mcepl@cepl.eu>2017-09-20 22:53:31 +0200
commit7927a8c628404c2b6734f80a24871f89e88a48d2 (patch)
treef3ad331f9b684c5c57b6cbed13ca242300902c2e /setup.py
parentb338a99307373d0edb9cd6a577c8480c9c0a9518 (diff)
downloadm2crypto-7927a8c628404c2b6734f80a24871f89e88a48d2.tar.gz
Fix setup.py sdist and release0.26.2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 5 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 3107877..3407c82 100644
--- a/setup.py
+++ b/setup.py
@@ -13,7 +13,6 @@ Copyright 2008-2011 Heikki Toivonen. All rights reserved.
import glob
import os
import platform
-import re
import string
import subprocess
import sys
@@ -21,11 +20,9 @@ import sys
from distutils.command import build, sdist
from distutils.command.clean import clean
from distutils.dir_util import mkpath
-from distutils.file_util import copy_file
from distutils.version import StrictVersion
import setuptools
-
from setuptools.command import build_ext
REQUIRED_SWIG_VERSION = '2.0.4'
@@ -78,14 +75,13 @@ def openssl_version(req_ver, required=False):
class _M2CryptoSDist(sdist.sdist):
- '''Specialization of build to enable swig_opts to inherit any
- include_dirs settings made at the command line or in a setup.cfg file'''
+ """Make sure we don't run sdist with old OpenSSL."""
def run(self):
- if openssl_version(MAXIMUM_OPENSSL_VERSION):
+ if openssl_version(MAXIMUM_OPENSSL_VERSION, True):
sdist.sdist.run(self)
else:
raise OSError(
- 'We cannot use OpenSSL version more recent than %s!' %
+ 'We need OpenSSL version at least %s!' %
MAXIMUM_OPENSSL_VERSION)
@@ -236,6 +232,7 @@ def swig_version(req_ver):
return StrictVersion(ver_str) >= StrictVersion(req_ver)
+
x_comp_args = set()
if sys.platform == 'darwin':
x_comp_args.add("-Wno-deprecated-declarations")
@@ -295,6 +292,7 @@ def __get_version(): # noqa
if line.startswith('__version__ ='):
return line.split('=')[1].strip(string.whitespace + "'")
+
long_description_text = '''\
M2Crypto is the most complete Python wrapper for OpenSSL featuring RSA, DSA,
DH, EC, HMACs, message digests, symmetric ciphers (including AES); SSL