summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2019-11-25 00:33:12 +0100
committerMatěj Cepl <mcepl@cepl.eu>2019-11-25 00:37:31 +0100
commitffb065feab15d9e508ec372e1ed55b0219ca6837 (patch)
tree0da4ba31a93582e6015319664be0114e41617d43 /setup.py
parent1e9e9d674d80681e11f25c3546882f8d53698cb1 (diff)
downloadm2crypto-ffb065feab15d9e508ec372e1ed55b0219ca6837.tar.gz
Revert using typing module in 2.6. It is just not worthy.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 5 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 2ce9424..83d8b24 100644
--- a/setup.py
+++ b/setup.py
@@ -36,16 +36,14 @@ log = logging.getLogger('setup')
REQUIRED_SWIG_VERSION = '2.0.4'
-if sys.version_info[:2] <= (2, 6):
- sys.path.insert(0, os.path.join(os.path.abspath(os.path.dirname(__file__)),
- 'tests', 'vendor'))
-
+requires_list = []
if (2, 6) < sys.version_info[:2] < (3, 5):
requires_list = ['typing']
-else:
- requires_list = []
+if sys.version_info[0] > 2:
from typing import Dict, List
+
+
package_data = {} # type: Dict[str, List[str]]
if sys.platform == 'win32':
package_data.update(M2Crypto=["*.dll"])
@@ -344,6 +342,7 @@ class Clean(clean):
if os.path.exists(f):
os.unlink(f)
+
def __get_version(): # noqa
with open('M2Crypto/__init__.py') as init_file:
for line in init_file: