summaryrefslogtreecommitdiff
path: root/tests/test_asn1.py
diff options
context:
space:
mode:
authorHeikki Toivonen <heikki@heikkitoivonen.net>2006-12-15 00:17:00 +0000
committerHeikki Toivonen <heikki@heikkitoivonen.net>2006-12-15 00:17:00 +0000
commitcc79fc74eb80257d67837c0ea54e60efa32b7eaf (patch)
treec9a06a9a42e2e80144ce1a7e200b7e054773ce0c /tests/test_asn1.py
parent381167f5d6add76b9461c30d2dabf156e3ff3f04 (diff)
downloadm2crypto-cc79fc74eb80257d67837c0ea54e60efa32b7eaf.tar.gz
Make all test methods start with test_, so that running individual suites works,
for example: python setup.py test --test-suite=tests.test_x509 -q git-svn-id: http://svn.osafoundation.org/m2crypto/trunk@504 2715db39-9adf-0310-9c64-84f055769b4b
Diffstat (limited to 'tests/test_asn1.py')
-rw-r--r--tests/test_asn1.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/tests/test_asn1.py b/tests/test_asn1.py
index d3adb16..349f592 100644
--- a/tests/test_asn1.py
+++ b/tests/test_asn1.py
@@ -9,13 +9,13 @@ from M2Crypto import ASN1, m2
class ASN1TestCase(unittest.TestCase):
- def check_Integer(self):
+ def test_Integer(self):
pass # XXX Dunno how to test
- def check_BitSTring(self):
+ def test_BitSTring(self):
pass # XXX Dunno how to test
- def check_String(self):
+ def test_String(self):
asn1ptr = m2.asn1_string_new()
text = 'hello there'
# In RFC2253 format:
@@ -26,10 +26,10 @@ class ASN1TestCase(unittest.TestCase):
assert a.as_text() == 'hello there', a.as_text()
assert a.as_text(flags=m2.ASN1_STRFLGS_RFC2253) == '#040B68656C6C6F207468657265', a.as_text(flags=m2.ASN1_STRFLGS_RFC2253)
- def check_Object(self):
+ def test_Object(self):
pass # XXX Dunno how to test
- def check_UTCTIME(self):
+ def test_UTCTIME(self):
asn1 = ASN1.ASN1_UTCTIME()
assert str(asn1) == 'Bad time value'
@@ -57,7 +57,7 @@ class ASN1TestCase(unittest.TestCase):
def suite():
- return unittest.makeSuite(ASN1TestCase, 'check')
+ return unittest.makeSuite(ASN1TestCase)
if __name__ == '__main__':