summaryrefslogtreecommitdiff
path: root/tests/test_bio_ssl.py
diff options
context:
space:
mode:
authorHeikki Toivonen <heikki@heikkitoivonen.net>2006-12-06 07:40:15 +0000
committerHeikki Toivonen <heikki@heikkitoivonen.net>2006-12-06 07:40:15 +0000
commit80771b3cd7313efc732544768262d849c9c33534 (patch)
treeaac27bdf9e521946e0e714caaf2dfd0a03e4a509 /tests/test_bio_ssl.py
parent1a5f26d38a1322be3884b70c3d2f94685b7bf909 (diff)
downloadm2crypto-80771b3cd7313efc732544768262d849c9c33534.tar.gz
Bug 7077, test command to setup.py. setuptools are now required to run unit tests.
git-svn-id: http://svn.osafoundation.org/m2crypto/trunk@491 2715db39-9adf-0310-9c64-84f055769b4b
Diffstat (limited to 'tests/test_bio_ssl.py')
-rw-r--r--tests/test_bio_ssl.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/test_bio_ssl.py b/tests/test_bio_ssl.py
index e40fef9..b07be03 100644
--- a/tests/test_bio_ssl.py
+++ b/tests/test_bio_ssl.py
@@ -23,7 +23,7 @@ class HandshakeClient(threading.Thread):
def run(self):
ctx = SSL.Context()
- ctx.load_cert_chain("server.pem")
+ ctx.load_cert_chain("tests/server.pem")
conn = SSL.Connection(ctx)
cipher_list = conn.get_cipher_list()
sslbio = BIO.SSLBio()
@@ -103,7 +103,7 @@ class SSLTestCase(unittest.TestCase):
def check_do_handshake_succeed(self):
ctx = SSL.Context()
- ctx.load_cert_chain("server.pem")
+ ctx.load_cert_chain("tests/server.pem")
conn = SSL.Connection(ctx)
self.sslbio.set_ssl(conn)
readbio = BIO.MemoryBuffer()