summaryrefslogtreecommitdiff
path: root/tests/test_ec_curves.py
diff options
context:
space:
mode:
authorHeikki Toivonen <heikki@heikkitoivonen.net>2006-12-15 00:17:00 +0000
committerHeikki Toivonen <heikki@heikkitoivonen.net>2006-12-15 00:17:00 +0000
commitcc79fc74eb80257d67837c0ea54e60efa32b7eaf (patch)
treec9a06a9a42e2e80144ce1a7e200b7e054773ce0c /tests/test_ec_curves.py
parent381167f5d6add76b9461c30d2dabf156e3ff3f04 (diff)
downloadm2crypto-cc79fc74eb80257d67837c0ea54e60efa32b7eaf.tar.gz
Make all test methods start with test_, so that running individual suites works,
for example: python setup.py test --test-suite=tests.test_x509 -q git-svn-id: http://svn.osafoundation.org/m2crypto/trunk@504 2715db39-9adf-0310-9c64-84f055769b4b
Diffstat (limited to 'tests/test_ec_curves.py')
-rw-r--r--tests/test_ec_curves.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/test_ec_curves.py b/tests/test_ec_curves.py
index 8607dcc..fcc7b1e 100644
--- a/tests/test_ec_curves.py
+++ b/tests/test_ec_curves.py
@@ -135,7 +135,7 @@ class ECCurveTests(unittest.TestCase):
assert ec.verify_dsa(self.data, r, s)
assert not ec.verify_dsa(self.data, s, r)
- def check_ec_curves_ECDSA(self):
+ def test_ec_curves_ECDSA(self):
for curveName, curveLen in curves:
self.sign_verify_ecdsa(curveName, curveLen)
@@ -148,7 +148,7 @@ class ECCurveTests(unittest.TestCase):
def suite():
suite = unittest.TestSuite()
- suite.addTest(unittest.makeSuite(ECCurveTests, 'check'))
+ suite.addTest(unittest.makeSuite(ECCurveTests))
return suite