summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml29
1 files changed, 29 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 0000000..8d25f73
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,29 @@
+image: python:2.7
+
+test:
+ script:
+ - apt-get -y swig libssl-dev libssl1.0.0
+ - python setup.py test
+
+# language: python
+#
+# addons:
+# apt:
+# packages:
+# - swig
+# - libssl-dev
+# - libssl1.0.0
+#
+# sudo: false
+#
+# python:
+# - 2.6
+# - 2.7
+#
+# before_script:
+# - '[ "${TRAVIS_PYTHON_VERSION}" = "2.6" ] && pip install --use-mirrors unittest2 || /bin/true'
+#
+# install:
+# - python setup.py install
+#
+# script: python setup.py test