summaryrefslogtreecommitdiff
path: root/.gitlab-ci.yml
diff options
context:
space:
mode:
Diffstat (limited to '.gitlab-ci.yml')
-rw-r--r--.gitlab-ci.yml11
1 files changed, 11 insertions, 0 deletions
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index c0d0342..7927dc6 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -3,6 +3,7 @@ stages:
# - python26
- python27
- python34
+ - fedora
.python26:
stage: python26
@@ -11,6 +12,16 @@ stages:
script:
- python setup.py clean build test
+fedora:
+ stage: fedora
+ image: fedora:latest
+ when: always
+ script:
+ # - dnf upgrade --refresh -y
+ - dnf install -y @development-tools fedora-packager rpmdevtools
+ - dnf install -y swig python-devel openssl-devel openssl python-setuptools python-twisted
+ - python setup.py build test
+
centos6:
stage: centos6
image: centos:6