summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES2
-rw-r--r--setup.py1
2 files changed, 3 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index f15c305..1703f26 100644
--- a/CHANGES
+++ b/CHANGES
@@ -9,6 +9,8 @@
- m2xmlrpclib.py fixed to work with Python 2.5, by Miloslav Trmac
- 64-bit correctness fixes, by Miloslav Trmac
- Added SSL session caching support to HTTPSConnection, by Keith Jackson
+- Fixed build problem affecting certain systems where OpenSSL was built without
+ EC support
- M2CRYPTO_TEST_SSL_SLEEP environment variable controls how long to sleep
after starting the test SSL server. Default is 0.5, but 0.1 or even 0.05
might work with modern computers. Makes tests finish significantly faster.
diff --git a/setup.py b/setup.py
index 3e51f69..68d71c6 100644
--- a/setup.py
+++ b/setup.py
@@ -112,6 +112,7 @@ m2crypto = Extension(name='M2Crypto.__m2crypto',
extra_compile_args = ['-DTHREADING'],
#extra_link_args = ['-Wl,-search_paths_first'], # Uncomment to build Universal Mac binaries
swig_opts = [swig_opts_str,
+ -includeall',
#'-D__i386__', # Uncomment for early OpenSSL 0.9.7 versions
]
)