summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2010-03-05 19:58:28 +0000
committerMike Bayer <mike_mp@zzzcomputing.com>2010-03-05 19:58:28 +0000
commitd9a5683418771c8842fe5ad748cef656c8123c19 (patch)
treee30a6a6e40687a53fae820eaa990f880ef63382d
parent81b0b90d83aaff20a92f3823dca9660b5b6e6775 (diff)
downloadmako-rel_0_3_0.tar.gz
tweaksrel_0_3_0
-rw-r--r--README.py3k4
-rw-r--r--setup.py2
2 files changed, 4 insertions, 2 deletions
diff --git a/README.py3k b/README.py3k
index cf51731..c5329eb 100644
--- a/README.py3k
+++ b/README.py3k
@@ -50,5 +50,7 @@ can be acquired from Bitbucket using Mercurial:
cd nose3
python3 setup.py install
-The tests can then be run using the "nosetests3" script installed by the above.
+The tests can then be run using the "nosetests3" script installed
+by the above (python3 setup.py test doesn't seem to be working with
+nose3).
diff --git a/setup.py b/setup.py
index 25360fc..1da839d 100644
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,7 @@ if sys.version_info >= (3, 0):
use_2to3=True,
)
-v = file(os.path.join(os.path.dirname(__file__), 'mako', '__init__.py'))
+v = open(os.path.join(os.path.dirname(__file__), 'mako', '__init__.py'))
VERSION = re.compile(r".*__version__ = '(.*?)'", re.S).match(v.read()).group(1)
v.close()