summaryrefslogtreecommitdiff
path: root/mako/compat.py
diff options
context:
space:
mode:
authorHugo <hugovk@users.noreply.github.com>2018-01-16 13:23:21 -0500
committerMike Bayer <mike_mp@zzzcomputing.com>2018-01-16 13:23:21 -0500
commita582879d89ac6e37b9daa8b3c820ebedddad2aea (patch)
treec52c26b30292db25cbef0a89021c205dd0ccb44f /mako/compat.py
parent200398c6fba989a7f72779e62fd326b28d12cdf2 (diff)
downloadmako-a582879d89ac6e37b9daa8b3c820ebedddad2aea.tar.gz
Remove redundant Python<2.6 code
Includes PR https://github.com/zzzeek/mako/pull/26 so [Travis CI passes](https://travis-ci.org/hugovk/mako/builds/329346809). The last two commits are unique to this PR. --- Since Mako 1.0.0, Python 2.6 has been the minimum supported version: > [general] Compatibility changes; in order to modernize the codebase, Mako is now dropping support for Python 2.4 and Python 2.5 altogether. The source base is now targeted at Python 2.6 and forwards. http://docs.makotemplates.org/en/latest/changelog.html#change-b602a175c0ec26eaa4f42962d23cca96 This removes redundant code only relevant to Python 2.5 or earlier. It also adds `python_requires` to setup.py, so pip won't install this version on Python 2.5 or earlier. For people with older versions, pip will install the next Mako version down. Are all Python 3.x versions supported? If not, I'll add those to `python_requires` as well. Change-Id: I624e1d56e79555c579278c7a5b4de9498179ffe9 Pull-request: https://github.com/zzzeek/mako/pull/27
Diffstat (limited to 'mako/compat.py')
-rw-r--r--mako/compat.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/mako/compat.py b/mako/compat.py
index a2ab243..312bbd8 100644
--- a/mako/compat.py
+++ b/mako/compat.py
@@ -4,7 +4,6 @@ import time
py3k = sys.version_info >= (3, 0)
py33 = sys.version_info >= (3, 3)
py2k = sys.version_info < (3,)
-py26 = sys.version_info >= (2, 6)
py27 = sys.version_info >= (2, 7)
jython = sys.platform.startswith('java')
win32 = sys.platform.startswith('win')