summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2019-07-27 12:01:10 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2019-07-27 12:34:21 -0400
commit338cad687a1f49b021e81d33fd16847a4c5c7731 (patch)
treeceb6b8a2574a950705b8421913fe380a797d05a6 /setup.py
parenta79fbaad5fe507e6fce76c891d0793444be6d6e1 (diff)
downloadmako-338cad687a1f49b021e81d33fd16847a4c5c7731.tar.gz
Bump Python versions, remove conditional imports
Mako 1.1 now supports Python versions: * 2.7 * 3.4 and higher This includes that setup.py no longer includes any conditionals, allowing for a pure Python wheel build, however this is not necessarily part of the Pypi release process as of yet. The test suite also raises for Python deprecation warnings. Fixes: #249 Replaced usage of ``inspect.getfullargspec()`` with the vendored version used by SQLAlchemy, Alembic to avoid future deprecation warnings. Also cleans up an additional version of the same function that's apparently been floating around for some time. Fixes: #295 Change-Id: I98274c16b6022289d1890f4daf532bab323ab112
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 5 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index 17b6c70..68b46ef 100644
--- a/setup.py
+++ b/setup.py
@@ -14,24 +14,9 @@ VERSION = (
)
v.close()
-readme = open(os.path.join(os.path.dirname(__file__), "README.rst")).read()
+readme = os.path.join(os.path.dirname(__file__), "README.rst")
-if sys.version_info < (2, 6):
- raise Exception("Mako requires Python 2.6 or higher.")
-
-markupsafe_installs = (
- sys.version_info >= (2, 6) and sys.version_info < (3, 0)
-) or sys.version_info >= (3, 3)
-
-install_requires = []
-
-if markupsafe_installs:
- install_requires.append("MarkupSafe>=0.9.2")
-
-try:
- import argparse # noqa
-except ImportError:
- install_requires.append("argparse")
+install_requires = ["MarkupSafe>=0.9.2"]
class PyTest(TestCommand):
@@ -59,7 +44,8 @@ setup(
version=VERSION,
description="A super-fast templating language that borrows the \
best ideas from the existing templating languages.",
- long_description=readme,
+ long_description=open(readme).read(),
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
classifiers=[
"Development Status :: 5 - Production/Stable",
"License :: OSI Approved :: MIT License",
@@ -77,14 +63,13 @@ setup(
url="https://www.makotemplates.org/",
project_urls={
"Documentation": "https://docs.makotemplates.org",
- "Issue Tracker": "https://github.com/sqlalchemy/mako"
+ "Issue Tracker": "https://github.com/sqlalchemy/mako",
},
license="MIT",
packages=find_packages(".", exclude=["examples*", "test*"]),
tests_require=["pytest", "mock"],
cmdclass={"test": PyTest},
zip_safe=False,
- python_requires=">=2.6",
install_requires=install_requires,
extras_require={},
entry_points="""