summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES31
-rw-r--r--doc/build/genhtml.py2
-rw-r--r--setup.py2
-rw-r--r--test/cache.py3
-rw-r--r--test/template.py2
5 files changed, 22 insertions, 18 deletions
diff --git a/CHANGES b/CHANGES
index ac42c4f..f79576f 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,18 +1,23 @@
+0.1.4
- got defs-within-defs to be cacheable
-- fixes to code parsing/whitespace adjusting where plain python
-comments may contain quote characters [ticket:23]
-- fix to variable scoping for identifiers only referenced within functions
-- added a path normalization step to lookup so URIs like "/foo/bar/../etc/../foo"
-pre-process the ".." tokens before checking the filesystem
-- fixed/improved "caller" semantics so that undefined caller is "UNDEFINED",
-propigates __nonzero__ method so it evaulates to False if not present,
-True otherwise. this way you can say % if caller:\n ${caller.body()}\n% endif
-- <%include> has an "args" attribute that can pass arguments to the called
-template (keyword arguments only, must be declared in that page's <%page> tag.)
+- fixes to code parsing/whitespace adjusting where plain python comments
+ may contain quote characters [ticket:23]
+- fix to variable scoping for identifiers only referenced within
+ functions
+- added a path normalization step to lookup so URIs like
+ "/foo/bar/../etc/../foo" pre-process the ".." tokens before checking
+ the filesystem
+- fixed/improved "caller" semantics so that undefined caller is
+ "UNDEFINED", propigates __nonzero__ method so it evaulates to False if
+ not present, True otherwise. this way you can say % if caller:\n
+ ${caller.body()}\n% endif
+- <%include> has an "args" attribute that can pass arguments to the
+ called template (keyword arguments only, must be declared in that
+ page's <%page> tag.)
- <%include> plus arguments is also programmatically available via
-self.include_file(<filename>, **kwargs)
-- further escaping added for multibyte expressions in %def, %call attributes
-[ticket:24]
+ self.include_file(<filename>, **kwargs)
+- further escaping added for multibyte expressions in %def, %call
+ attributes [ticket:24]
0.1.3
diff --git a/doc/build/genhtml.py b/doc/build/genhtml.py
index a045afc..15e6282 100644
--- a/doc/build/genhtml.py
+++ b/doc/build/genhtml.py
@@ -24,7 +24,7 @@ files = [
]
title='Mako Documentation'
-version = '0.1.3'
+version = '0.1.4'
root = toc.TOCElement('', 'root', '', version=version, doctitle=title)
diff --git a/setup.py b/setup.py
index c9eabf5..f1b9ca0 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup, find_packages
-version = '0.1.3'
+version = '0.1.4'
setup(name='Mako',
version=version,
diff --git a/test/cache.py b/test/cache.py
index b9f3e71..f6f318f 100644
--- a/test/cache.py
+++ b/test/cache.py
@@ -63,7 +63,6 @@ class CacheTest(unittest.TestCase):
callcount: ${callcount}
""")
m = self._install_mock_cache(t)
- print t.code
assert result_lines(t.render()) == [
'this is foo',
'this is foo',
@@ -229,4 +228,4 @@ class CacheTest(unittest.TestCase):
return m
if __name__ == '__main__':
- unittest.main() \ No newline at end of file
+ unittest.main()
diff --git a/test/template.py b/test/template.py
index 196fefc..9e3f0d6 100644
--- a/test/template.py
+++ b/test/template.py
@@ -38,7 +38,7 @@ class EncodingTest(unittest.TestCase):
val = u"""<%text>Alors vous imaginez ma surprise, au lever du jour, quand une drôle de petit voix m’a réveillé. Elle disait: « S’il vous plaît… dessine-moi un mouton! »</%text>"""
val = "## -*- coding: utf-8 -*-\n" + val.encode('utf-8')
template = Template(val)
- print template.code
+ #print template.code
assert template.render_unicode() == u"""Alors vous imaginez ma surprise, au lever du jour, quand une drôle de petit voix m’a réveillé. Elle disait: « S’il vous plaît… dessine-moi un mouton! »"""
def test_unicode_text_ccall(self):