summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..f36bfc6
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,35 @@
+#!/usr/bin/env python
+import os
+import re
+
+try:
+ from setuptools import setup, Extension
+except ImportError:
+ from distutils.core import setup, Extension
+
+
+if os.path.isfile("MANIFEST"):
+ os.unlink("MANIFEST")
+
+
+version = re.search('__version__ = "([^"]+)"',
+ open("mocker.py").read()).group(1)
+
+setup(
+ name="mocker",
+ version=version,
+ description="Graceful platform for test doubles in Python (mocks, stubs, fakes, and dummies).",
+ author="Gustavo Niemeyer",
+ author_email="gustavo@niemeyer.net",
+ license="PSF License",
+ url="http://labix.org/mocker",
+ download_url="https://launchpad.net/mocker/+download",
+ classifiers=[
+ "Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Python Software Foundation License",
+ "Programming Language :: Python",
+ "Topic :: Software Development :: Testing",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ],
+)