summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGraham Dumpleton <Graham.Dumpleton@gmail.com>2014-06-08 17:44:42 +1000
committerGraham Dumpleton <Graham.Dumpleton@gmail.com>2014-06-08 17:44:42 +1000
commit64bfa70c34d0e09e5135fe8e407d636e2f6bc625 (patch)
tree75b44ecb6dbe6bf9dbae9b8a92568d0188796ba7 /setup.py
parenta20bb40fce1085c25212c7e0f38af8afcb4a0eea (diff)
downloadmod_wsgi-metrics-64bfa70c34d0e09e5135fe8e407d636e2f6bc625.tar.gz
Initial version of code.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py37
1 files changed, 37 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..8be306f
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,37 @@
+from __future__ import print_function
+
+from setuptools import setup
+
+setup_kwargs = dict(
+ name = 'mod_wsgi-metrics',
+ version = '1.0.0',
+ description = 'Metrics package for Apache/mod_wsgi.',
+ author = 'Graham Dumpleton',
+ author_email = 'Graham.Dumpleton@gmail.com',
+ maintainer = 'Graham Dumpleton',
+ maintainer_email = 'Graham.Dumpleton@gmail.com',
+ url = 'http://www.modwsgi.org/',
+ license = 'Apache License, Version 2.0',
+ platforms = [],
+ download_url = None,
+ classifiers= [
+ 'Development Status :: 6 - Mature',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: MacOS :: MacOS X',
+ 'Operating System :: POSIX',
+ 'Operating System :: POSIX :: BSD',
+ 'Operating System :: POSIX :: Linux',
+ 'Operating System :: POSIX :: SunOS/Solaris',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI',
+ ],
+ packages = ['mod_wsgi', 'mod_wsgi.metrics', 'mod_wsgi.metrics.newrelic'],
+ package_dir = {'mod_wsgi': 'src'},
+)
+
+setup(**setup_kwargs)