summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraham Dumpleton <Graham.Dumpleton@gmail.com>2022-07-18 14:16:19 +1000
committerGraham Dumpleton <Graham.Dumpleton@gmail.com>2022-07-18 14:16:19 +1000
commit92a73134ddb09d2545ec3d26061df2d856610b30 (patch)
tree4eebca7644c286327e53e9337a71d0ba49179275
parent2e4e11842c52d7253dd8cae3dcfca551369dc3e0 (diff)
downloadmod_wsgi-92a73134ddb09d2545ec3d26061df2d856610b30.tar.gz
Update Apache version for mod_wsgi-standalone to 2.4.54.
-rw-r--r--README-standalone.rst21
-rw-r--r--setup.py2
2 files changed, 16 insertions, 7 deletions
diff --git a/README-standalone.rst b/README-standalone.rst
index 440e38c..f702fbb 100644
--- a/README-standalone.rst
+++ b/README-standalone.rst
@@ -10,8 +10,8 @@ The primary package for mod_wsgi is available on the Python package index
version of Apache pre-installed on your target system, and if you don't,
installation of the package will fail.
-If you are on a UNIX like system (Linux, macOS) and need a version of
-Apache to be installed for you, you can use the ``mod_wsgi-standalone``
+If you are on a UNIX like system (Linux) and need a version of Apache
+to be installed for you, you can use the ``mod_wsgi-standalone``
package on PyPi instead. When installing the ``mod_wsgi-standalone``
package it will first trigger the installation of the ``mod_wsgi-httpd``
package, which will result in a version of Apache being installed as
@@ -19,12 +19,21 @@ part of your Python installation. Next the ``mod_wsgi`` package will be
installed, with it using the version of Apache installed by the
``mod_wsgi-httpd`` package rather than any system package for Apache.
-Note that this method of installation is only suitable for where you want
-to use ``mod_wsgi-express``. It cannot be used to build mod_wsgi for use
-with your system Apache installation. This installation method will also
-not work on Windows.
+This method of installation is only suitable for where you want to use
+``mod_wsgi-express``. It cannot be used to build mod_wsgi for use with
+your system Apache installation. This installation method will not
+work on Windows, and also currently fails on macOS because the Apache
+Runtime (APR) library, has not been updated to latest macOS versions.
When installing mod_wsgi using this method, except that you will install
the ``mod_wsgi-standalone`` package instead of the ``mod_wsgi`` package,
you should follow installation and usage instructions outlined on the
PyPi page for the ``mod_wsgi`` package.
+
+**NOTE: Although this package may allow you to install a standalone Apache
+version, it is only really recommended that you use this package if you
+have absolutely no other choice for getting the Apache httpd server
+installed. Always use the Apache httpd server supplied with the operating
+system if you can. Building this package if you do choose to do so, will
+take some time. So if you you think the install is hanging, it is probably
+still busy compiling everything.**
diff --git a/setup.py b/setup.py
index 9878047..e0c8c84 100644
--- a/setup.py
+++ b/setup.py
@@ -466,5 +466,5 @@ setup(name = package_name,
entry_points = { 'console_scripts':
['mod_wsgi-express = mod_wsgi.server:main'],},
zip_safe = False,
- install_requires = standalone and ['mod_wsgi-httpd==2.4.48.1'] or [],
+ install_requires = standalone and ['mod_wsgi-httpd==2.4.54.1'] or [],
)