summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGraham.Dumpleton <devnull@localhost>2007-12-22 03:51:22 +0000
committerGraham.Dumpleton <devnull@localhost>2007-12-22 03:51:22 +0000
commit2903249edd9d7429cd2c49f1bfdbfdb3a9e1a193 (patch)
treea063effbc0a2f8bdb19f7869310ddd3b0bae07b9 /configure.ac
parent36c9cec33d490903aac20565c5624d0e51fac119 (diff)
downloadmod_wsgi-2903249edd9d7429cd2c49f1bfdbfdb3a9e1a193.tar.gz
Disable WSGIHandlerScript for now. Add --disable-embedded option to configure
so that the feature can be disabled at compile time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c1c5468..fe6b385 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,6 +18,11 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(mod_wsgi.c)
+AC_ARG_ENABLE(embedded, AC_HELP_STRING([--disable-embedded],
+ [disable mod_wsgi embedded mode]),
+ [ENABLE_EMBEDDED=$enableval],
+ [ENABLE_EMBEDDED=yes])
+
AC_ARG_WITH(apxs, AC_HELP_STRING([--with-apxs=NAME],
[name of the apxs executable [[apxs]]]),
[APXS="$with_apxs"])
@@ -55,7 +60,13 @@ CPPFLAGS2=`${PYTHON} -c 'from distutils import sysconfig; \
print " ".join(filter(lambda x: x.startswith("-D"), \
sysconfig.get_config_var("CFLAGS").split()))'`
-CPPFLAGS="${CPPFLAGS1} ${CPPFLAGS2}"
+if test "${ENABLE_EMBEDDED}" != "yes"; then
+CPPFLAGS3="-DMOD_WSGI_DISABLE_EMBEDDED"
+else
+CPPFLAGS3=""
+fi
+
+CPPFLAGS="${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3}"
AC_SUBST(CPPFLAGS)