summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGraham Dumpleton <Graham.Dumpleton@gmail.com>2014-10-29 18:28:23 +1100
committerGraham Dumpleton <Graham.Dumpleton@gmail.com>2014-10-29 18:28:23 +1100
commit97025f36a40e5874bebf28a3e7decf0c212cd889 (patch)
tree17d9b7af8bc942301250eda66cf49e59dca234a5 /configure.ac
parentc64952d1b979fcff329b4963ab5ac85e4cf65fe3 (diff)
downloadmod_wsgi-97025f36a40e5874bebf28a3e7decf0c212cd889.tar.gz
Fix up configure script for MacOS X 10.10.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 13 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a974e71..f3f1d09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,15 +39,24 @@ fi
XCODE_PREFIX="/Applications/Xcode.app/Contents/Developer/Toolchains/"
XCODE_CC="${XCODE_PREFIX}XcodeDefault.xctoolchain/usr/bin/cc"
+XCODE_BIN_PATTERN="${XCODE_PREFIX}.*/usr/bin/"
if test -x "${APXS}"; then
APXS_CC=`${APXS} -q CC`
APXS_LIBTOOL=`${APXS} -q LIBTOOL | sed -e "s/ .*$//"`
if [[[ ${APXS_CC} = ${XCODE_PREFIX}* ]]]; then
- cat "${APXS_LIBTOOL}" | sed -e \
- "s/OSX10.[[89]].xctoolchain/XcodeDefault.xctoolchain/" > ./libtool
- cat "${APXS}" | sed -e "s%get_vars(\"CC\")%\"${XCODE_CC}\"%" \
- -e 's%^my $libtool = .*;%my $libtool = \"./libtool\";%' > ./apxs
+ if test ! -x ${XCODE_CC}; then
+ cat "${APXS_LIBTOOL}" | sed -e \
+ "s%${XCODE_BIN_PATTERN}%/usr/bin/%" > ./libtool
+ cat "${APXS}" | sed -e "s%get_vars(\"CC\")%\"/usr/bin/cc\"%" \
+ -e 's%^my $libtool = .*;%my $libtool = \"./libtool\";%' > ./apxs
+ else
+ cat "${APXS_LIBTOOL}" | sed -e \
+ "s%OSX10.[[0-9]][[0-9]]*.xctoolchain%XcodeDefault.xctoolchain%" > ./libtool
+ cat "${APXS}" | sed -e "s%get_vars(\"CC\")%\"${XCODE_CC}\"%" \
+ -e 's%^my $libtool = .*;%my $libtool = \"./libtool\";%' > ./apxs
+ fi
+
chmod +x ./apxs ./libtool
APXS=./apxs
fi