summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGraham.Dumpleton <devnull@localhost>2009-09-25 12:01:50 +0000
committerGraham.Dumpleton <devnull@localhost>2009-09-25 12:01:50 +0000
commit9752bc5158973b7addfe720a44fab0aeeb3a1e79 (patch)
tree01e2180398ba906fc9d0dd4b590ce3c9c1355764 /configure.ac
parent8ef69e1b2aeec394da5fea8ca54df501b93cce51 (diff)
downloadmod_wsgi-9752bc5158973b7addfe720a44fab0aeeb3a1e79.tar.gz
Remove need to enable compilations on Python 3.X.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index d6b1264..9f40d9e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,11 +28,6 @@ AC_ARG_ENABLE(embedded, AC_HELP_STRING([--disable-embedded],
[ENABLE_EMBEDDED=$enableval],
[ENABLE_EMBEDDED=yes])
-AC_ARG_ENABLE(py3k, AC_HELP_STRING([--enable-py3k],
- [enable mod_wsgi Python 3.X support]),
- [ENABLE_PY3K=$enableval],
- [ENABLE_PY3K=no])
-
AC_ARG_WITH(apxs, AC_HELP_STRING([--with-apxs=NAME],
[name of the apxs executable [[apxs]]]),
[APXS="$with_apxs"])
@@ -97,13 +92,7 @@ else
CPPFLAGS3=""
fi
-if test "${ENABLE_PY3K}" = "yes"; then
-CPPFLAGS4="-DMOD_WSGI_ENABLE_PY3K"
-else
-CPPFLAGS4=""
-fi
-
-CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3} ${CPPFLAGS4}"
+CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3}"
AC_SUBST(CPPFLAGS)