summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGraham.Dumpleton <devnull@localhost>2009-08-12 05:30:57 +0000
committerGraham.Dumpleton <devnull@localhost>2009-08-12 05:30:57 +0000
commitd8abbced282085e7d0469d441e3a7f8b3757596e (patch)
treef7d4a94508861d281b80a2c5326b8f0d54ea6f1d /configure.ac
parenteb5a49cb83d9f4f41c550f68d73fc72b29c84c11 (diff)
downloadmod_wsgi-d8abbced282085e7d0469d441e3a7f8b3757596e.tar.gz
Require configure option to enable Python 3.X support. For Windows, will need
to manually modify makefile to provide require preprocessor define to enable it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ebac745..9db0d1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,6 +23,11 @@ AC_ARG_ENABLE(embedded, AC_HELP_STRING([--disable-embedded],
[ENABLE_EMBEDDED=$enableval],
[ENABLE_EMBEDDED=yes])
+AC_ARG_ENABLE(py3k, AC_HELP_STRING([--enable-py3k],
+ [enable mod_wsgi Python 3.X support]),
+ [ENABLE_PY3K=$enableval],
+ [ENABLE_PY3K=no])
+
AC_ARG_WITH(apxs, AC_HELP_STRING([--with-apxs=NAME],
[name of the apxs executable [[apxs]]]),
[APXS="$with_apxs"])
@@ -87,7 +92,13 @@ else
CPPFLAGS3=""
fi
-CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3}"
+if test "${ENABLE_PY3K}" = "yes"; then
+CPPFLAGS4="-DMOD_WSGI_ENABLE_PY3K"
+else
+CPPFLAGS4=""
+fi
+
+CPPFLAGS="${CPPFLAGS} ${CPPFLAGS1} ${CPPFLAGS2} ${CPPFLAGS3} ${CPPFLAGS4}"
AC_SUBST(CPPFLAGS)