summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGraham.Dumpleton <devnull@localhost>2009-05-22 04:25:36 +0000
committerGraham.Dumpleton <devnull@localhost>2009-05-22 04:25:36 +0000
commite084562e1db364f66ecd83b59277d0b9c9149d7c (patch)
tree4448c22ec43f49b1cd5b44b50a52b23910dedd9a /configure.ac
parent9eeeedb1daa6a7c04235fa142c37304149433e10 (diff)
downloadmod_wsgi-e084562e1db364f66ecd83b59277d0b9c9149d7c.tar.gz
Only use -L/-l on MacOS X if Python 2.6 or later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ab56f44..9c4ffab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,7 +102,10 @@ if test "${PYTHONFRAMEWORKDIR}" = "no-framework"; then
from distutils import sysconfig; \
stdout.write(sysconfig.get_config_var("SYSLIBS"))'`
else
- if test -f "${PYTHONCFGDIR}/libpython${PYTHON_VERSION}.a"; then
+ if test "${PYTHON_VERSION}" != "2.3" && \
+ test "${PYTHON_VERSION}" != "2.4" && \
+ test "${PYTHON_VERSION}" != "2.5" && \
+ test -f "${PYTHONCFGDIR}/libpython${PYTHON_VERSION}.a"; then
LDFLAGS2="-L${PYTHONCFGDIR}"
LDLIBS1="-lpython${PYTHON_VERSION}"