summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGraham Dumpleton <Graham.Dumpleton@gmail.com>2015-02-02 14:14:32 +1100
committerGraham Dumpleton <Graham.Dumpleton@gmail.com>2015-02-02 14:14:32 +1100
commit6cdc9e85681b1efe95987516ef57a323866da034 (patch)
tree1f73c129494fedbefafb22474ebea20adacf509f /setup.py
parent3ff9a3d42fbe68988b421fe94f18c6d633cb8ceb (diff)
downloadmod_wsgi-6cdc9e85681b1efe95987516ef57a323866da034.tar.gz
Shouldn't be merging apxs config vars.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 0 insertions, 23 deletions
diff --git a/setup.py b/setup.py
index 36bdd57..b6b71db 100644
--- a/setup.py
+++ b/setup.py
@@ -197,29 +197,6 @@ if WITH_TARBALL_PACKAGE:
CONFIG['SBINDIR'] = get_apxs_config('sbindir')
CONFIG['PROGNAME'] = get_apxs_config('progname')
- _CFLAGS_NAMES = ['SHLTCFLAGS', 'CFLAGS', 'NOTEST_CPPFLAGS',
- 'EXTRA_CPPFLAGS', 'EXTRA_CFLAGS']
-
- _CFLAGS_VALUES = []
-
- for name in _CFLAGS_NAMES:
- value = get_apxs_config(name)
-
- # Heroku doesn't appear to run the same version of gcc
- # that a standard Ubuntu installation does and which was
- # used to originally build the Apache binaries. We need
- # therefore to strip out flags that the Heroku gcc may
- # not understand.
-
- if value:
- if os.path.isdir('/app/.heroku'):
- value = value.replace('-prefer-pic', '')
-
- if value:
- _CFLAGS_VALUES.append(value)
-
- CONFIG['CFLAGS'] = ' '.join(_CFLAGS_VALUES)
-
else:
def get_apxs_config(query):
p = subprocess.Popen([APXS, '-q', query],