summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGraham Dumpleton <Graham.Dumpleton@gmail.com>2014-09-15 07:58:28 +1000
committerGraham Dumpleton <Graham.Dumpleton@gmail.com>2014-09-15 07:58:28 +1000
commit6ecca5b973b2d80bbe5e20ef5a92767910f5a28a (patch)
treefc40bddaa699f4baa673550fbb4964858d35b4f4 /setup.py
parent41e4d73d308ab7a49485bdb1419ac7453ab5538d (diff)
downloadmod_wsgi-6ecca5b973b2d80bbe5e20ef5a92767910f5a28a.tar.gz
Failed to commit calculation of where rotate logs resides to setup.py. #9
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index fbaf719..69ff1e5 100644
--- a/setup.py
+++ b/setup.py
@@ -75,9 +75,17 @@ elif os.path.exists(os.path.join(BINDIR, PROGNAME)):
else:
HTTPD = PROGNAME
+if os.path.exists(os.path.join(SBINDIR, 'rotatelogs')):
+ ROTATELOGS = os.path.join(SBINDIR, 'rotatelogs')
+elif os.path.exists(os.path.join(BINDIR, 'rotatelogs')):
+ ROTATELOGS = os.path.join(BINDIR, 'rotatelogs')
+else:
+ ROTATELOGS = 'rotatelogs'
+
with open(os.path.join(os.path.dirname(__file__),
'src/server/apxs_config.py'), 'w') as fp:
print('HTTPD = "%s"' % HTTPD, file=fp)
+ print('ROTATELOGS = "%s"' % ROTATELOGS, file=fp)
print('BINDIR = "%s"' % BINDIR, file=fp)
print('SBINDIR = "%s"' % SBINDIR, file=fp)
print('PROGNAME = "%s"' % PROGNAME, file=fp)