summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGraham Dumpleton <Graham.Dumpleton@gmail.com>2017-11-14 19:06:40 +1100
committerGraham Dumpleton <Graham.Dumpleton@gmail.com>2017-11-14 19:06:40 +1100
commit8e57570b3aa2938e9cfbee7eaed10b06990607b0 (patch)
tree264b6b6f5efcaea43befc3ea9e0756331f6c0eba /setup.py
parent6614be82e045a99c2780b56dfe93dd9af5fd9da7 (diff)
downloadmod_wsgi-8e57570b3aa2938e9cfbee7eaed10b06990607b0.tar.gz
Add defaults for MacOS X when no apxs.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 12 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index aabe34d..f0c92b5 100644
--- a/setup.py
+++ b/setup.py
@@ -184,7 +184,18 @@ if WITH_WINDOWS_APACHE:
elif WITH_MACOSX_APACHE:
def get_apxs_config(name):
- return ''
+ if name == 'BINDIR':
+ return '/usr/bin'
+ elif name == 'SBINDIR':
+ return '/usr/sbin'
+ elif name == 'LIBEXECDIR':
+ return '/usr/libexec/apache2'
+ elif name == 'PROGNAME':
+ return 'httpd'
+ elif name == 'SHLIBPATH_VAR':
+ return 'DYLD_LIBRARY_PATH'
+ else:
+ return ''
def get_apr_includes():
return ''