summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authordglasser <dglasser@b1010a0a-674b-0410-b734-77272b80c875>2008-06-18 23:30:15 +0000
committerdglasser <dglasser@b1010a0a-674b-0410-b734-77272b80c875>2008-06-18 23:30:15 +0000
commit7f2c742a739a4a81009d0be82d29bbde0cecd222 (patch)
tree44814b08390ef0853611cb749678e480712d4317
parent2e0f37c942510f734cbd29b27275f1676c595506 (diff)
downloadmox-7f2c742a739a4a81009d0be82d29bbde0cecd222.tar.gz
Write a README.
git-svn-id: http://pymox.googlecode.com/svn/trunk@12 b1010a0a-674b-0410-b734-77272b80c875
-rw-r--r--README57
1 files changed, 56 insertions, 1 deletions
diff --git a/README b/README
index 9cf8aeb..5e1fe78 100644
--- a/README
+++ b/README
@@ -1 +1,56 @@
-TODO(glasser): README!
+Mox is an open source mock object framework for Python, inspired by
+the Java library EasyMock.
+
+To install:
+
+ $ python setup.py install
+
+To run Mox's internal tests:
+
+ $ python mox_test.py
+
+Basic usage:
+
+ import unittest
+ import mox
+
+ class PersonTest(mox.MoxTestBase):
+
+ def testUsingMox(self):
+ # Create a mock Person
+ mock_person = self.mox.CreateMock(Person)
+
+ test_person = ...
+ test_primary_key = ...
+ unknown_person = ...
+
+ # Expect InsertPerson to be called with test_person; return
+ # test_primary_key at that point
+ mock_person.InsertPerson(test_person).AndReturn(test_primary_key)
+
+ # Raise an exception when this is called
+ mock_person.DeletePerson(unknown_person).AndRaise(UnknownPersonError())
+
+ # Switch from record mode to replay mode
+ self.mox.ReplayAll()
+
+ # Run the test
+ ret_pk = mock_person.InsertPerson(test_person)
+ self.assertEquals(test_primary_key, ret_pk)
+ self.assertRaises(UnknownPersonError, mock_person, unknown_person)
+
+For more documentation, see:
+
+ http://code.google.com/p/pymox/wiki/MoxDocumentation
+
+For more information, see:
+
+ http://code.google.com/p/pymox/
+
+Our user and developer discussion group is:
+
+ http://groups.google.com/group/mox-discuss
+
+Mox is Copyright 2008 Google Inc, and licensed under the Apache
+License, Version 2.0; see the file COPYING for details. If you would
+like to help us improve Mox, join the group.