summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Willmer <alex@moreati.org.uk>2021-01-27 01:11:32 +0000
committerGitHub <noreply@github.com>2021-01-27 10:11:32 +0900
commit02e1f7623cd8d0fcd4763d542fc60e2957ee2046 (patch)
treef4961200949dd0ac83f57abb7e19fafa73e73619
parent3b71818bb0e4cbafdb58895fa47704563448b6ac (diff)
downloadmsgpack-python-master.tar.gz
build: Create tox environments using a known Cython version (#408)master
This change causes Tox to run the project's setup.py in a virtualenv (default path is .tox/.package). The required version of Cython is installed, rather than whatever version is installed system wide.
-rw-r--r--pyproject.toml8
-rw-r--r--requirements.txt1
-rw-r--r--tox.ini1
3 files changed, 10 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..a9eb8aa
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,8 @@
+[build-system]
+requires = [
+ # Also declared in requirements.txt, if updating here please also update
+ # there
+ "Cython~=0.29.13",
+ "setuptools >= 35.0.2",
+]
+build-backend = "setuptools.build_meta"
diff --git a/requirements.txt b/requirements.txt
index a2cce25..180fe85 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1 +1,2 @@
+# Also declared in pyproject.toml, if updating here please also update there
Cython~=0.29.13
diff --git a/tox.ini b/tox.ini
index 607b182..ace1ba9 100644
--- a/tox.ini
+++ b/tox.ini
@@ -5,6 +5,7 @@ envlist =
{pypy,pypy3}-pure,
py27-x86,
py34-x86,
+isolated_build = true
[variants:pure]
setenv=