summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorINADA Naoki <methane@users.noreply.github.com>2017-01-13 21:46:31 +0900
committerGitHub <noreply@github.com>2017-01-13 21:46:31 +0900
commit3388e4a6ee6adea56789d97cc05ed610a4e5b4fc (patch)
tree562af61a9d593b0ef50e288439d2ef2f37d1138e
parentb328f3ecffd22e7f0db76e81774727fd171bf303 (diff)
downloadmsgpack-python-3388e4a6ee6adea56789d97cc05ed610a4e5b4fc.tar.gz
travis and appveyor update (#217)
travis: * stop using tox * Add Python 3.6 and 3.7-dev * Stop pypy3 (until PyPy3.5 is released) appveyor: * Drop Python 3.4 and add 3.6
-rw-r--r--.travis.yml34
-rw-r--r--appveyor.yml8
-rwxr-xr-xdocker/runtests.sh2
3 files changed, 28 insertions, 16 deletions
diff --git a/.travis.yml b/.travis.yml
index b4396cb..0170360 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,22 +1,23 @@
sudo: false
language: python
-python: 3.5
-cache:
- directories:
- - $HOME/.cache/pip
+cache: pip
+
+python:
+ - "2.7"
+ - "3.3"
+ - "3.4"
+ - "3.5"
+ - "3.6"
+ - "3.7-dev"
branches:
only:
- master
-env:
- - TOXENV=py27-c,py33-c,py34-c,py35-c
- - TOXENV=py27-pure,py33-pure,py34-pure,py35-pure
- - TOXENV=pypy-pure,pypy3-pure
-
matrix:
include:
- sudo: required
+ language: c
services:
- docker
env:
@@ -28,12 +29,23 @@ matrix:
- docker pull $DOCKER_IMAGE
script:
- docker run --rm -v `pwd`:/io -w /io $DOCKER_IMAGE /io/docker/runtests.sh
+ - python: "pypy"
+ install:
+ - pip install -e .
+ script:
+ - py.test -v test
+
install:
- pip install -U pip
- - pip install tox cython
+ - pip install cython
- cython --cplus msgpack/_packer.pyx msgpack/_unpacker.pyx
+ - pip install -e .
-script: tox
+script:
+ - python -c 'import sys; print(hex(sys.maxsize))'
+ - python -c 'from msgpack import _packer, _unpacker'
+ - py.test -v test
+ - MSGPACK_PUREPYTHON=x py.test -v test
# vim: sw=2 ts=2
diff --git a/appveyor.yml b/appveyor.yml
index a8a2352..e63423d 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -8,16 +8,16 @@ environment:
# isn't covered by this document) at the time of writing.
- PYTHON: "C:\\Python27"
- - PYTHON: "C:\\Python34"
- - PYTHON: "C:\\Python35"
- PYTHON: "C:\\Python27-x64"
- - PYTHON: "C:\\Python34-x64"
- DISTUTILS_USE_SDK: "1"
+ - PYTHON: "C:\\Python35"
- PYTHON: "C:\\Python35-x64"
+ - PYTHON: "C:\\Python36"
+ - PYTHON: "C:\\Python36-x64"
install:
# We need wheel installed to build wheels
- "%PYTHON%\\python.exe -m pip install -U pip wheel pytest cython"
+ - "%PYTHON%\\Scripts\\cython --cplus msgpack/_packer.pyx msgpack/_unpacker.pyx"
build: off
diff --git a/docker/runtests.sh b/docker/runtests.sh
index 0d74802..0eea715 100755
--- a/docker/runtests.sh
+++ b/docker/runtests.sh
@@ -1,7 +1,7 @@
#!/bin/bash
set -e -x
-for V in cp35-cp35m cp34-cp34m cp27-cp27m cp27-cp27mu; do
+for V in cp36-cp36m cp35-cp35m cp34-cp34m cp27-cp27m cp27-cp27mu; do
PYBIN=/opt/python/$V/bin
$PYBIN/python setup.py install
rm -rf build/ # Avoid lib build by narrow Python is used by wide python