summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2012-06-26 17:27:29 +0900
committerINADA Naoki <songofacandy@gmail.com>2012-06-26 17:27:29 +0900
commitebe4c1f4bc31bc1f47831d72819cac5a2a584604 (patch)
tree9ad8cb9a9f114ea8603f94dd50fd1458357bd59a
parent58eb7d0ce857b0ffb5e0ee4addf5ad1b3b47afa9 (diff)
downloadmsgpack-python-ebe4c1f4bc31bc1f47831d72819cac5a2a584604.tar.gz
manage to compile on windows
Use C++ compiler to build.
-rw-r--r--msgpack/_msgpack.pyx4
-rw-r--r--msgpack/pack.h2
-rw-r--r--[-rwxr-xr-x]setup.py1
3 files changed, 4 insertions, 3 deletions
diff --git a/msgpack/_msgpack.pyx b/msgpack/_msgpack.pyx
index 990f585..526c003 100644
--- a/msgpack/_msgpack.pyx
+++ b/msgpack/_msgpack.pyx
@@ -222,8 +222,8 @@ def unpackb(object packed, object object_hook=None, object list_hook=None, bint
template_init(&ctx)
ctx.user.use_list = use_list
ctx.user.object_hook = ctx.user.list_hook = NULL
- ctx.user.encoding = enc
- ctx.user.unicode_errors = err
+ ctx.user.encoding = <const_char_ptr>enc
+ ctx.user.unicode_errors = <const_char_ptr>err
if object_hook is not None:
if not PyCallable_Check(object_hook):
raise TypeError("object_hook must be a callable.")
diff --git a/msgpack/pack.h b/msgpack/pack.h
index d36b436..4c0373e 100644
--- a/msgpack/pack.h
+++ b/msgpack/pack.h
@@ -77,7 +77,7 @@ static inline int msgpack_pack_write(msgpack_packer* pk, const char *data, size_
if (len + l > bs) {
bs = (len + l) * 2;
- buf = realloc(buf, bs);
+ buf = (char*)realloc(buf, bs);
if (!buf) return -1;
}
memcpy(buf + len, data, l);
diff --git a/setup.py b/setup.py
index 7e78b4c..149b282 100755..100644
--- a/setup.py
+++ b/setup.py
@@ -53,6 +53,7 @@ msgpack_mod = Extension('msgpack._msgpack',
sources=sources,
libraries=libraries,
include_dirs=['.'],
+ language='c++',
)
del sources, libraries