summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2018-01-09 20:48:45 +0900
committerINADA Naoki <songofacandy@gmail.com>2018-01-09 20:48:45 +0900
commite0934355c6534690d3c80ea8659d51c65a55ee0f (patch)
tree21d2a8fe174c60f4f005550a870a0e7b689d85c0 /Makefile
parent676bbcd0eee2a6e8aece5239e380c12ea633375a (diff)
downloadmsgpack-python-e0934355c6534690d3c80ea8659d51c65a55ee0f.tar.gz
Update Makefile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile27
1 files changed, 11 insertions, 16 deletions
diff --git a/Makefile b/Makefile
index f833bbc..84decd8 100644
--- a/Makefile
+++ b/Makefile
@@ -1,32 +1,27 @@
-.PHONY: test all python3
-
+.PHONY: all
all: cython
python setup.py build_ext -i -f
-doc-serve: all
- cd docs && make serve
-
-doc:
- cd docs && make zip
-
-upload-doc:
- python setup.py upload_docs --upload-dir docs/_build/html
-
+.PHONY: cython
cython:
cython --cplus msgpack/*.pyx
-python3: cython
- python3 setup.py build_ext -i -f
-
+.PHONY: test
test:
- py.test test
+ py.test -v test
+
+.PHONY: serve-doc
+serve-doc: all
+ cd docs && make serve
.PHONY: clean
clean:
rm -rf build
rm msgpack/*.so
rm -rf msgpack/__pycache__
+ rm -rf test/__pycache__
-build-manylinux1-wheel:
+.PHONY: linux-wheel
+linux-wheel:
docker run --rm -ti -v `pwd`:/project -w /project quay.io/pypa/manylinux1_i686 bash docker/buildwheel.sh
docker run --rm -ti -v `pwd`:/project -w /project quay.io/pypa/manylinux1_x86_64 bash docker/buildwheel.sh