summaryrefslogtreecommitdiff
path: root/docker
diff options
context:
space:
mode:
authorInada Naoki <songofacandy@gmail.com>2021-11-16 16:19:47 +0900
committerGitHub <noreply@github.com>2021-11-16 16:19:47 +0900
commitb3f72541925cda3b018942db45a59936184727e3 (patch)
treecc292c34c376f7ee2065fc215a1ba322702c45f5 /docker
parent9b84e490e7c78ac9bbd76dcf9ce71c1d0c978d81 (diff)
downloadmsgpack-python-b3f72541925cda3b018942db45a59936184727e3.tar.gz
Support Python 3.10 and Drop Python 3.5 (#487)
* linux: Use manylinux2014 * mac: Drop Python 3.6 too
Diffstat (limited to 'docker')
-rw-r--r--docker/buildwheel.sh4
-rw-r--r--docker/shared.env2
2 files changed, 4 insertions, 2 deletions
diff --git a/docker/buildwheel.sh b/docker/buildwheel.sh
index 89a2570..ff34139 100644
--- a/docker/buildwheel.sh
+++ b/docker/buildwheel.sh
@@ -7,10 +7,12 @@ set -e -x
ARCH=`uname -p`
echo "arch=$ARCH"
+ls /opt/python
+
for V in "${PYTHON_VERSIONS[@]}"; do
PYBIN=/opt/python/$V/bin
rm -rf build/ # Avoid lib build by narrow Python is used by wide python
- $PYBIN/python setup.py bdist_wheel
+ $PYBIN/python -m build -w
done
cd dist
diff --git a/docker/shared.env b/docker/shared.env
index 3601a07..80274ac 100644
--- a/docker/shared.env
+++ b/docker/shared.env
@@ -1,7 +1,7 @@
PYTHON_VERSIONS=(
+ cp310-cp310
cp39-cp39
cp38-cp38
cp37-cp37m
cp36-cp36m
- cp35-cp35m
)